[IPython-dev] Ipython - dev on debian sid (zmq suppport)

Julian Taylor jtaylor.debian@googlemail....
Sun Oct 30 08:22:24 CDT 2011


On 10/30/2011 02:18 PM, massimo di stefano wrote:
> Hi All,
> 
> i'm tring to install Ipython (git version) on my linux debian (sid 64 bit)
> unlucky i'm not able to add the zmq support,
> because of a mismatch in the dependence.
> the message i had is about the zmq version :
> 
> IPython.zmq requires pyzmq >= 2.1.4, but you have 2.1.10
> 
> i guess there is something wrong ...  2.1.10 should be > 2.1.4 , is it ?
> 
> the configure script return the same worning :
> 
> 
> Please, have you any clue on what's going wrong ?
> 

This is issue 870:
https://github.com/ipython/ipython/issues/870

The startup bug should be fixed with the latest git. The message at
configure time is not fixed yet, but you can ignore that.

Debian sid does not have pyzmq 2.1.10 yet, thus it is not yet fixed in
the debian package.
A fixed ipython will be uploaded at the same time as pyzmq 2.1.10.

Best Regards,
Julian Taylor

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: OpenPGP digital signature
Url : http://mail.scipy.org/pipermail/ipython-dev/attachments/20111030/d1fd2437/attachment.bin 


More information about the IPython-dev mailing list