[IPython-dev] AttributeError when running sphinx docs

Aaron Meurer asmeurer@gmail....
Fri Aug 10 22:22:47 CDT 2012


Oh, and if you use return codes to determine if the build passes or
not, you might need to do something like
https://github.com/sympy/sympy/commit/b41a87a209227f43f67c99f6bee648699e9a538b.

Aaron Meurer

On Fri, Aug 10, 2012 at 8:21 PM, Aaron Meurer <asmeurer@gmail.com> wrote:
> We are getting a lot of these in SymPy too, sometimes getting them and
> sometimes not.  I think it might be a bug in Sphinx or numpydoc.
> Otherwise, make sure that you have the right type (i.e., autofunction,
> automethod, etc.).
>
> By the way, for SymPy, we've added docs building to our sympy-bot, as
> it's the only way that people even consider this in pull requests.
> Perhaps you might consider the same for your test_pr.  Otherwise,
> people don't even know that things are not Sphinx friendly, and the
> build errors just accumulate.
>
> Aaron Meurer
>
> On Fri, Aug 10, 2012 at 6:40 PM, Brian Granger <ellisonbg@gmail.com> wrote:
>> When I run "make html" to build the sphinx docs, I see a long sequence
>> of AttributeErrors - all on IPython attributes that clearly exist.
>> All of these are happening in the autodoc sphinx extension.  I have a
>> vague recollection of seeing this before but have no idea what I did
>> to get it to run.  Has anyone seen this or know what is going on?
>>
>> Cheers,
>>
>> Brian
>>
>> --
>> Brian E. Granger
>> Cal Poly State University, San Luis Obispo
>> bgranger@calpoly.edu and ellisonbg@gmail.com
>> _______________________________________________
>> IPython-dev mailing list
>> IPython-dev@scipy.org
>> http://mail.scipy.org/mailman/listinfo/ipython-dev


More information about the IPython-dev mailing list