[IPython-dev] Installation of ipython on cygwin

Arnaud Gardelein arnaud@oscopy....
Fri Aug 31 00:19:53 CDT 2012


It seems that ipython got installed fine on my cygwin install. Just in
case if it could help anybody else here is the approximate procedure that
was followed:
1. Install main dependencies with cygwin's setup.exe.
2. Download source and install libffi [1] (this prevent an error of
pkg-config see [3]#about libffi)
3. Download source and install matplotlib disabling Tkagg [2] and
following instruction of [3], set also
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
4. Download source and install ipython

And then:
$ ipython --pylab
Python 2.6.8 (unknown, Jun  9 2012, 11:30:32)
(...)
IPython 0.13 -- An enhanced Interactive Python.
(...)
In [1]: hist([1, 2, 3])
Out[1]:
(array([1, 0, 0, 0, 0, 1, 0, 0, 0, 1]),
 array([ 1. ,  1.2,  1.4,  1.6,  1.8,  2. ,  2.2,  2.4,  2.6,  2.8,  3. ]),
 <a list of 10 Patch objects>)

In [2]: plot([1,2,3],[4,5,9])
Out[2]: [<matplotlib.lines.Line2D at 0x7df49dec>]

The two Figures are shown.

Versions used:
Windows: XP pro
Cygwin: 1.7.16-i686-2.6
Python: 2.6.8
Matplotlib: 1.1.1
IPython: 0.13

[1] http://sourceware.org/libffi/
[2]
http://stackoverflow.com/questions/5151755/how-to-install-matplotlib-on-cygwin
[3] http://innuendopoly.org/arch/matplotlib-cygwin

Arnaud.




More information about the IPython-dev mailing list