[IPython-dev] IPEP-4: Python 3 Compatibility

Bradley M. Froehle brad.froehle@gmail....
Mon Oct 1 21:05:19 CDT 2012


Hi,

I'd like to introduce "IPEP-4: Python 3 Compatibility", the fourth IPython
Enhancement Proposal.

https://github.com/ipython/ipython/wiki/IPython-Enhancement-Proposals-(IPEPs)
https://github.com/ipython/ipython/wiki/IPEP-4:-Python-3-Compatibility

As you likely know, currently running ``python3 ipython.py`` does not work
out of the box, as the source code we ship is only natively compatible with
Python 2.6 and 2.7. Our excellent support for Python 3.2 and 3.3 relies on
first running the source code through 2to3 (i.e., ``python3 setup,py build``).

This proposal suggests a number of modifications to the IPython source
to allow the code to be run in Python 2.6, 2.7 and 3.3 without the use of
2to3.  Python 3.2 compatibility would be maintained through continued use
of 2to3.

If you are interested in fulfilling the "instant running" promise
``python3.3 ipython.py`` or detest the (invasive?) required source code
changes and think we should defer this project until a later date, here is
what you should do:

1. Read the draft IPEP:

https://github.com/ipython/ipython/wiki/IPEP-4:-Python-3-Compatibility

2. Discuss the IPEP in this email thread and/or in the Github issue queue:

https://github.com/ipython/ipython/issues/2440

3. Help us edit the IPEP as the discussion moves along.

Cheers,
Brad


More information about the IPython-dev mailing list