[IPython-dev] [SciPy-User] Pylab - standard packages

Thomas Kluyver takowl@gmail....
Sat Sep 22 10:04:56 CDT 2012


On 22 September 2012 14:46, Ralf Gommers <ralf.gommers@gmail.com> wrote:
> I think you have forwards and backwards compatible the wrong way around.
> Forwards compatible would be that you can open version 4 files, if that's
> introduced in IPython 0.14 or later, in 0.13.

You're quite right, I had the terms backwards. Sorry about that; I do
find them confusing.

> In my opinion you need either
> forward compatibility or by default keep saving in version 3 even after you
> have version 4, if you want to make the format a standard.

Well, if we make version 4, it would be because we were making a
change that couldn't be opened by the v3 code - that's what the
version numbers are for. But, as I understand it, we've made v3
considerably more extensible, so most of the things we've considered
adding wouldn't need a version number bump.

In the future, I envisage that if/when we define a new version, we'll
have a transition period where the notebook can open version n+1, but
defaults to saving as version n. Then once that ability is widespread,
we'd make the next release save as n+1 by default.

I've CCed the ipython-dev list: Fernando, Brian, Min, can you give
some more insight on how stable the notebook format is now?

Thanks,
Thomas


More information about the IPython-dev mailing list