[IPython-dev] Couldn't import IPython.zmq in ipython3

wang aiyong wangaiyongff@gmail....
Sun Apr 7 01:42:48 CDT 2013


Sorry, I just mishit a button and sent the email out without finished.
Continue:
since my pyzmq =13.0 >2.1.4
so I just "import IPython.zmq" in ipython3, then an error came out:

In [2]: import IPython.zmq
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-2-b3d4e8cf6bab> in <module>()
----> 1 import IPython.zmq

D:\Python33\lib\site-packages\IPython\zmq\__init__.py in <module>()
     65         RuntimeWarning)
     66
---> 67 check_for_zmq('2.1.4')
     68 patch_pyzmq()
     69

D:\Python33\lib\site-packages\IPython\zmq\__init__.py in
check_for_zmq(minimum_v
ersion, module)
     51         import zmq
     52     except ImportError:
---> 53         raise ImportError("%s requires pyzmq >= %s"%(module,
minimum_ver
sion))
     54
     55     pyzmq_version = zmq.__version__

ImportError: IPython.zmq requires pyzmq >= 2.1.4

In [3]:

Can anybody tell where I'm doing wrong?


2013/4/7 wang aiyong <wangaiyongff@gmail.com>

> I'm using Windows xp sp3, installed python3.3, ipython0.13 by
> 'ipython-0.13.2.py3-win32'. I  had pyqt, distribute, pip, etc installed. I
> alse followed installation instruction on "
> http://ipython.org/ipython-doc/rel-0.13/install/install.html#installation-from-source"
> website. I installed ZeroMQ3.2 ( 2.2.0 also tried), Pyzmq 13.0.2.
> But when I was about to install MathJax like this: "from
> IPython.external.mathjax import install_mathjax", I got an error as follows:
>
> In [1]: from IPython.external.mathjax import install_mathjax
> ---------------------------------------------------------------------------
> ImportError                               Traceback (most recent call last)
> <ipython-input-1-01ec93d75f9e> in <module>()
> ----> 1 from IPython.external.mathjax import install_mathjax
>
> D:\Python33\lib\site-packages\IPython\external\mathjax.py in <module>()
>      24 import tarfile
>      25
> ---> 26 from IPython.frontend.html import notebook as nbmod
>      27
>      28
> #-----------------------------------------------------------------------
> ------
>
> D:\Python33\lib\site-packages\IPython\frontend\html\notebook\__init__.py
> in <mod
> ule>()
>      16
>      17 # check for pyzmq 2.1.4
> ---> 18 from IPython.zmq import check_for_zmq
>      19 check_for_zmq('2.1.4', 'IPython.frontend.html.notebook')
>      20 del check_for_zmq
>
> D:\Python33\lib\site-packages\IPython\zmq\__init__.py in <module>()
>      65         RuntimeWarning)
>      66
> ---> 67 check_for_zmq('2.1.4')
>      68 patch_pyzmq()
>      69
>
> D:\Python33\lib\site-packages\IPython\zmq\__init__.py in
> check_for_zmq(minimum_v
> ersion, module)
>      51         import zmq
>      52     except ImportError:
> ---> 53         raise ImportError("%s requires pyzmq >= %s"%(module,
> minimum_ver
> sion))
>      54
>      55     pyzmq_version = zmq.__version__
>
> ImportError: IPython.zmq requires pyzmq >= 2.1.4
>
> In [2]:
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20130407/469608a9/attachment-0001.html 


More information about the IPython-dev mailing list