[IPython-dev] Couldn't import IPython.zmq in ipython3

wang aiyong wangaiyongff@gmail....
Sun Apr 7 20:49:44 CDT 2013


I'm new to this mailing list. I can find my message on the url "
http://mail.scipy.org/pipermail/ipython-dev/2013-April/011335.html", but
why I didn't receive a mail in my gmail ? What's wrong?

Appreciate the response from *Thomas Kluyver* takowl@gmail....
<ipython-dev%40scipy.org?Subject=%5BIPython-dev%5D%20Couldn%27t%20import%20IPython.zmq%20in%20ipython3&In-Reply-To=CAHJCAaDiuxH2Z5He-BNdnP0umMige7w-x%2BFPcgLMPB7Zbm-duA%40mail.gmail.com>
.
When I import zmq directly from ipython3, I just got another error.
Sorry I couldn't show the precise error message, because I've kind of
solved the problem before I saw this response.
What I did is:
1. Download "pyzmq-13.0.2.win32-py3.3.exe" from "
http://www.lfd.uci.edu/~gohlke/pythonlibs/".
2. Instead of Open the 'exe' file directly, extract it to a folder. Then I
got a folder named "zmq", and a file named "pyzmq-13.0.2-py3.3.egg-info"
3. Copy both the folder and the file to "\python33\lib\site-packages\"
4. Done.

Still don't know the reason. I just got some idea from a chinese web page
of instruction of making a portable ipython notebook (of python2.7).


2013/4/7 wang aiyong <wangaiyongff@gmail.com>

> Sorry, I just mishit a button and sent the email out without finished.
> Continue:
> since my pyzmq =13.0 >2.1.4
> so I just "import IPython.zmq" in ipython3, then an error came out:
>
> In [2]: import IPython.zmq
> ---------------------------------------------------------------------------
> ImportError                               Traceback (most recent call last)
> <ipython-input-2-b3d4e8cf6bab> in <module>()
> ----> 1 import IPython.zmq
>
> D:\Python33\lib\site-packages\IPython\zmq\__init__.py in <module>()
>      65         RuntimeWarning)
>      66
> ---> 67 check_for_zmq('2.1.4')
>      68 patch_pyzmq()
>      69
>
> D:\Python33\lib\site-packages\IPython\zmq\__init__.py in
> check_for_zmq(minimum_v
> ersion, module)
>      51         import zmq
>      52     except ImportError:
> ---> 53         raise ImportError("%s requires pyzmq >= %s"%(module,
> minimum_ver
> sion))
>      54
>      55     pyzmq_version = zmq.__version__
>
> ImportError: IPython.zmq requires pyzmq >= 2.1.4
>
> In [3]:
>
> Can anybody tell where I'm doing wrong?
>
>
> 2013/4/7 wang aiyong <wangaiyongff@gmail.com>
>
>> I'm using Windows xp sp3, installed python3.3, ipython0.13 by
>> 'ipython-0.13.2.py3-win32'. I  had pyqt, distribute, pip, etc installed. I
>> alse followed installation instruction on "
>> http://ipython.org/ipython-doc/rel-0.13/install/install.html#installation-from-source"
>> website. I installed ZeroMQ3.2 ( 2.2.0 also tried), Pyzmq 13.0.2.
>> But when I was about to install MathJax like this: "from
>> IPython.external.mathjax import install_mathjax", I got an error as follows:
>>
>> In [1]: from IPython.external.mathjax import install_mathjax
>>
>> ---------------------------------------------------------------------------
>> ImportError                               Traceback (most recent call
>> last)
>> <ipython-input-1-01ec93d75f9e> in <module>()
>> ----> 1 from IPython.external.mathjax import install_mathjax
>>
>> D:\Python33\lib\site-packages\IPython\external\mathjax.py in <module>()
>>      24 import tarfile
>>      25
>> ---> 26 from IPython.frontend.html import notebook as nbmod
>>      27
>>      28
>> #-----------------------------------------------------------------------
>> ------
>>
>> D:\Python33\lib\site-packages\IPython\frontend\html\notebook\__init__.py
>> in <mod
>> ule>()
>>      16
>>      17 # check for pyzmq 2.1.4
>> ---> 18 from IPython.zmq import check_for_zmq
>>      19 check_for_zmq('2.1.4', 'IPython.frontend.html.notebook')
>>      20 del check_for_zmq
>>
>> D:\Python33\lib\site-packages\IPython\zmq\__init__.py in <module>()
>>      65         RuntimeWarning)
>>      66
>> ---> 67 check_for_zmq('2.1.4')
>>      68 patch_pyzmq()
>>      69
>>
>> D:\Python33\lib\site-packages\IPython\zmq\__init__.py in
>> check_for_zmq(minimum_v
>> ersion, module)
>>      51         import zmq
>>      52     except ImportError:
>> ---> 53         raise ImportError("%s requires pyzmq >= %s"%(module,
>> minimum_ver
>> sion))
>>      54
>>      55     pyzmq_version = zmq.__version__
>>
>> ImportError: IPython.zmq requires pyzmq >= 2.1.4
>>
>> In [2]:
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20130408/e99d9fd2/attachment.html 


More information about the IPython-dev mailing list