[IPython-dev] IPython + gevent compatibility

Alex Gaudio adgaudio@gmail....
Wed Feb 6 10:47:22 CST 2013


Hello all,

I did some research into how we could make IPython and gevent compatible
with each other, and after some discussion on
github<https://github.com/ipython/ipython/issues/2785>,
we decided the best way to integrate the two is execute a gevent.monkey
patch in the IPython launcher (or earlier).  As a follow-up to this, Thomas
Kluyver suggested I ask you all the following question:

Is anyone here be interested in IPython supporting a specific
ipython_gevent launcher?  It might look like this:

# EASY-INSTALL-ENTRY-SCRIPT: 'ipython==0.13.1','console_scripts','ipython'
__requires__ = 'ipython==0.13.1'
import sys
from pkg_resources import load_entry_point

*import gevent.monkey ; gevent.monkey.patch_all()*  *## monkey patch would
be added here  ##*

sys.exit(
   load_entry_point('ipython==0.13.1', 'console_scripts', 'ipython')()
)


Thanks for your time!
Alex
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20130206/9d12adb4/attachment.html 


More information about the IPython-dev mailing list