[IPython-dev] Rmagic under Debian Squeeze problem

Javier Martínez-López javi.martinez.lopez@gmail....
Mon Jan 21 04:37:02 CST 2013


ok, thanks! I think that I need Python 2.7 to run this version of rpy2, as
well:

import rpy2.rinterface

---------------------------------------------------------------------------AttributeError
                           Traceback (most recent call
last)<ipython-input-1-676c977874d9> in <module>()----> 1 import
rpy2.rinterface
/usr/local/lib/python2.6/dist-packages/rpy2/rinterface/__init__.py in
<module>()      1 import os, sys      2 ----> 3 if
(sys.version_info.major == 2) and (sys.version_info.minor < 7):      4
    raise RuntimeError("Python 2.7 or 3.3 are required to run rpy2")
   5
AttributeError: 'tuple' object has no attribute 'major'



On Mon, Jan 21, 2013 at 11:25 AM, Thomas Kluyver <takowl@gmail.com> wrote:

> On 21 January 2013 10:16, Javier Martínez-López <
> javi.martinez.lopez@gmail.com> wrote:
>
>> ok, I will try to upgrade to 2.7! Thanks
>
>
> To be clear, it's rpy2 that you need to upgrade, and the current release
> is 2.3.0. I mentioned the Python version because it indicates that your
> packages are a bit older, but IPython should work with Python 2.6.
>
> Thomas
>
> _______________________________________________
> IPython-dev mailing list
> IPython-dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20130121/eb939a49/attachment.html 


More information about the IPython-dev mailing list