[IPython-dev] Can't get sympy latex output to work

Thomas Kluyver takowl@gmail....
Sun Jun 30 15:30:23 CDT 2013


What version of Sympy are you using? I ran into this recently, and it
turned out there was a bug in 0.7.2 so that it doesn't enable the Latex
output by default. There's a way to force it to use latex, or you can use
development versions of Sympy until they get a new release out.

Thomas


On 30 June 2013 17:55, drrt <drrt@cs.utexas.edu> wrote:

> I have tried on the IPython version for Windows that comes with Enthought
> Canopy and the  latest pull from the dev version on a Mac.
>
> ugly.png <http://python.6.x6.nabble.com/file/n5023093/ugly.png>
> ugly_mat.png <http://python.6.x6.nabble.com/file/n5023093/ugly_mat.png>
>
> This doesn't work:
> from sympy import *
> %load_ext sympy.interactive.ipythonprinting
>
> after %reload_ext sympy.interactive.ipythonprinting
> it looks like the screenshots
>
> ipython notebook --profile=sympy seems to import and load things but the
> latex output doesn't work either
>
> ipython profile list
> Available profiles in IPython:
>     cluster
>     math
>     pysh
>     sympy
>
> Available profiles in /Users/drrt/.ipython:
>     default
>     sympy
>
>
> Any ideas? What else can I try?
>
>
>
> --
> View this message in context:
> http://python.6.x6.nabble.com/Can-t-get-sympy-latex-output-to-work-tp5023093.html
> Sent from the IPython - Development mailing list archive at Nabble.com.
> _______________________________________________
> IPython-dev mailing list
> IPython-dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20130630/3c3a1abe/attachment.html 


More information about the IPython-dev mailing list