[IPython-dev] Minimum virtualenv version for IPython development?

Tim Pitman tapitman11@gmail....
Mon Sep 23 20:40:11 CDT 2013


Hey all,

When using Python 2.7.5 built from source, and installing the latest
virtualenv, the following command from the IPython github page works fine:

pip install -e ".[notebook]"

However, when using Python 2.7.3 and virtualenv 1.7.1.2 from the Ubuntu
12.04 repos, the pip installed by virtualenv (apparently 1.1) fails to
execute that command with the following message:

--editable=.[notebook] should be formatted with svn+URL, git+URL, hg+URL or
bzr+UR

Seems like that version of pip is missing some newer features? Actually I
haven't been able to find documention for the -e ".[notebook]" syntax on
the pip site. Apparently it installs all of the dependencies for the
"notebook" entry in setup.py?

Basically my questions are:

Is there a minimum version of virtualenv/pip required for developing
IPython?

Is anyone developing off a system python from Ubuntu 12.04?

Thanks,
Tim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20130923/cac32566/attachment.html 


More information about the IPython-dev mailing list