[IPython-dev] Trouble installing latest IPython 2.0 on Mac

MinRK benjaminrk@gmail....
Fri Feb 14 13:01:50 CST 2014


So much hate for setuptools right now.  I can't believe `--no-deps` skips
dependency installation, but still adds a redundant check to entry points.

Yes, right now on Anaconda, you will need to *not* use setuptools to
install IPython dev. setup.py symlink is the best way to go, I think. Don't
worry, this won't be the case by the time we release 2.0.

-MinRK




On Fri, Feb 14, 2014 at 10:32 AM, Thomas Kluyver <takowl@gmail.com> wrote:

> On 14 February 2014 10:22, Alessandro Gagliardi <
> alessandro.gagliardi@glassdoor.com> wrote:
>
>> First:
>>
>> $ python setup.py symlink
>> . . .
>>
>>
>> Then:
>> $ python setup.py develop
>>
>
> setup.py symlink is an *alternative* to setup.py develop. You shouldn't
> need to run both.
>
> _______________________________________________
> IPython-dev mailing list
> IPython-dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20140214/dab7ef96/attachment.html 


More information about the IPython-dev mailing list