[IPython-dev] Trouble installing latest IPython 2.0 on Mac

Alessandro Gagliardi alessandro.gagliardi@glassdoor....
Fri Feb 14 13:14:41 CST 2014


$ python setup.py symlink
$ python setup.py install
worked.

Thanks!

From: Alessandro <alessandro.gagliardi@glassdoor.com<mailto:alessandro.gagliardi@glassdoor.com>>
Date: Friday, February 14, 2014 at 10:22 AM
To: "ipython-dev@scipy.org<mailto:ipython-dev@scipy.org>" <ipython-dev@scipy.org<mailto:ipython-dev@scipy.org>>
Subject: Re: [IPython-dev] Trouble installing latest IPython 2.0 on Mac

In case it matters, I’m doing this in a conda environment. I’ve run conda
install pip and conda install readline (etc.) ahead of time.
I try:
$ pip install --no-deps -e "[notebook]"
and it ends with

    Installed /Users/alessandro.gagliardi/Devel/ipython
Successfully installed ipython
Cleaning up…

But when I try
$ ipython
It gives me

Traceback (most recent call last):
  File "/Users/alessandro.gagliardi/anaconda/envs/ipython2/bin/ipython",
line 5, in <module>
    from pkg_resources import load_entry_point
  File
"/Users/alessandro.gagliardi/anaconda/envs/ipython2/lib/python2.7/site-pack
ages/setuptools-2.2-py2.7.egg/pkg_resources.py", line 2716, in <module>
  File
"/Users/alessandro.gagliardi/anaconda/envs/ipython2/lib/python2.7/site-pack
ages/setuptools-2.2-py2.7.egg/pkg_resources.py", line 685, in require
  File
"/Users/alessandro.gagliardi/anaconda/envs/ipython2/lib/python2.7/site-pack
ages/setuptools-2.2-py2.7.egg/pkg_resources.py", line 588, in resolve
pkg_resources.DistributionNotFound: readline


(FWIW, if I run strait up python and import readline, it works fine.)

Since that didn¹t work, I tried using setup.py as you recommended, but I
may have done it wrong. First:

$ python setup.py symlink
===========================================================================
=
BUILDING IPYTHON
                python: 2.7.6 |Continuum Analytics, Inc.| (default, Jan 10
                        2014, 11:23:15)  [GCC 4.0.1 (Apple Inc. build
5493)]
              platform: darwin

OPTIONAL DEPENDENCIES
                sphinx: Not found (required for docs and nbconvert)
              pygments: Not found (required for docs and nbconvert)
                  nose: 1.3.0
               pexpect: no (will use bundled version in IPython.external)
                 pyzmq: no (required for qtconsole, notebook, and parallel
                        computing capabilities)
               tornado: no (required for notebook)
              readline: yes
                jinja2: Not found (required for notebook and nbconvert)
running symlink
running install_lib_symlink
symlinking /Users/alessandro.gagliardi/Devel/ipython/IPython ->
/Users/alessandro.gagliardi/anaconda/envs/ipython2/lib/python2.7/site-packa
ges/IPython
running install_scripts_sym
running build_scripts
. . .


Then:
$ python setup.py develop
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20140214/8bae768e/attachment-0001.html 


More information about the IPython-dev mailing list