[IPython-dev] libreadline.so.5 missing in Canopy's IPython?

Brian Granger ellisonbg@gmail....
Fri Feb 21 11:42:00 CST 2014


This sounds like an issue with Canopy itself. Please contact Enthought
about the issue.

Cheers,

Brian

On Fri, Feb 21, 2014 at 9:35 AM, Name Name <zeitlinie@yahoo.de> wrote:
> I'm (partially) using IPython also out of Enthought's Canopy environment. Hopefully someone on this list is familiar with that.
>
> I just upgraded to version 1.3.0.1715 only to find that I could not invoke the simple 'non-notebook' IPython shell anymore without error because of a missing libreadline.so.5.
>
> I then realized, that indeed appdata/canopy-1.3.0.1715.rh5-x86_64/lib/ is lacking libreadline.so.5 completely(?)
> Also I realized that strangely/luckily appdata/canopy-1.1.0.1371.rh5-x86_64/lib/ of the earlier version was not deleted during update(?)
> Moreover the 'old' appdata/canopy-1.1.0.1371.rh5-x86_64/lib/ does contain libreadline.so.5
>
> After putting links to the 'old' libreadline.so.5 into the new appdata/canopy-1.3.0.1715.rh5-x86_64/lib/ the 'non-notebook' IPython shell starts again without error.
>
> Most likely all of this is not supposed to be. Does anyone have/had similar experiences? What am I missing here?
>
> _______________________________________________
> IPython-dev mailing list
> IPython-dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-dev



-- 
Brian E. Granger
Cal Poly State University, San Luis Obispo
bgranger@calpoly.edu and ellisonbg@gmail.com


More information about the IPython-dev mailing list