[IPython-dev] Camera widget

Sylvain Corlay sylvain.corlay@gmail....
Wed Feb 26 19:32:29 CST 2014


Hi Doug,
I have experienced this kind of problems with widgets not being rendered
because of caching issues of Chrome. Even after deleting the cache, some
javascript files are still not updated to the last version.
The fix for me is to
 -open the developer tools (Crtl + Shift + J)
 -right-click on the reload button of the page
 -choose *"Empty Cache and Hard Reload*".
Another solution which only works when the developer tools are kept open is
to check "*Disable cache (while DevTools is open)*" in the developer tools
options.
Best,
Sylvain


On Wed, Feb 26, 2014 at 8:02 PM, Doug Blank <doug.blank@gmail.com> wrote:

> On Wed, Feb 26, 2014 at 6:13 PM, Jason Grout <jason-sage@creativetrax.com>wrote:
>
>> On 2/26/14 4:25 PM, Doug Blank wrote:
>> > Jason, thank you very much for sharing this!
>> >
>> > So, I am testing this with IPython 2.0.0-dev master, and after three
>> > clicks, it no longer updates the imageurl field. The picture continues
>> > to be updated in the view, both live, and when the picture is taken. But
>> > it appears that the data is no longer being sent to the kernel.
>> >
>> > I have a feeling that this is because the frontend is not receiving a
>> > proper message back from the kernel (because auto throttling kicks in).
>> > This is my guess, anyway.
>> >
>> > Can you verify that you are also having this issue, and perhaps suggest
>> > what could be the matter.
>>
>> I'm running pretty close to master, and don't see it with this updated
>> version:
>>
>> http://nbviewer.ipython.org/gist/jasongrout/9210458
>>
>> (I didn't double-check the version I sent out earlier just now...it's
>> possible that one of the changes I made in the sagecell tweaks included
>> in the above version fixed the issue you are having)
>>
>>
> I'm seeing strange behavior in the latest pull (from today's changes in
> master) with all of the custom widgets. For example, the widgets in "Part 6
> Custom Widgets" in the examples are not rendering anymore.
>
> Any one else seeing that? Perhaps I need to recreate my profiles? The
> Camera widget no longer shows as well.
>
> -Doug
>
>
>>  Thanks,
>>
>> Jason
>>
>> _______________________________________________
>> IPython-dev mailing list
>> IPython-dev@scipy.org
>> http://mail.scipy.org/mailman/listinfo/ipython-dev
>>
>
>
> _______________________________________________
> IPython-dev mailing list
> IPython-dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20140226/57d10de7/attachment.html 


More information about the IPython-dev mailing list