Hi,<div><br></div><div>I tested it on Ubuntu Karmic Python 2.6, The r1350 (ipython-0.11.bzr.r1340-py2.6.) and there seemed to be 1 failure in IPython.core: </div><div><br></div><div><ul><li>FAIL: Test that object&#39;s __del__ methods are called on exit.</li>
</ul></div><div>(The other failure seems to be related)</div><div>Here is the complete traceback: <a href="http://gist.github.com/279386">http://gist.github.com/279386</a></div><div>Here is the traceback of the relevant section: <a href="http://gist.github.com/279387">http://gist.github.com/279387</a></div>
<div><br></div><div>Also, is there any quick reference (not necessarily explained and/or detailed), of all the new features/fixes in 0.11</div><div><br></div><div>Thanks.</div><div><br><div class="gmail_quote">On Sun, Jan 17, 2010 at 6:09 PM, Michele Mattioni <span dir="ltr">&lt;<a href="mailto:mattions@gmail.com">mattions@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><br><br><div class="gmail_quote"><div><div></div><div class="h5">On Sun, Jan 17, 2010 at 9:44 AM, Fernando Perez <span dir="ltr">&lt;<a href="http://fperez.net" target="_blank">fperez.net</a>@<a href="http://gmail.com" target="_blank">gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">
<div>On Sun, Jan 17, 2010 at 1:35 AM, Michele Mattioni &lt;<a href="mailto:mattions@gmail.com" target="_blank">mattions@gmail.com</a>&gt; wrote:<br>
&gt; I tried to test the qt integration but it seems it doesn&#39;t work properly.<br>
&gt;<br>
&gt; The ipython doesn&#39;t release the prompt as it should (an as it happens with<br>
&gt; 0.10)<br>
&gt;<br>
&gt; I attach a rough script (and adaptation of Mayavi qt embedding), just for<br>
&gt; testing purpose.<br>
<br>
</div>Mmh, unfortunately I can&#39;t seem to run your script, because I get a traceback:<br>
<br>
In [2]: run qt_embedding.py<br>
Warning: Unable to import the qt4 backend for pyface due to traceback:<br>
<div>Traceback (most recent call last):<br>
</div>          File &quot;/usr/lib/python2.6/dist-packages/enthought/pyface/toolkit.py&quot;,<br>
line 40, in _init_toolkit<br>
            __import__(be + &#39;init&#39;)<br>
        ImportError: No module named qt4.init<br>
<br>
Info: Unable to import any backend (qt4) for pyface; using the &#39;null&#39;<br>
toolkit instead.<br>
<br>
/usr/lib/python2.6/dist-packages/enthought/traits/ui/toolkit.py:128:<br>
UserWarning: Unable to import the &#39;qt4&#39; backend for traits UI; using<br>
the &#39;null&#39; toolkit instead.<br>
  &quot;using the &#39;null&#39; toolkit instead.&quot; % toolkit_name )<br>
---------------------------------------------------------------------------<br>
ImportError                               Traceback (most recent call last)<br>
<br>
/home/fperez/Desktop/qt_embedding.py in &lt;module&gt;()<br>
     17     Int, Dict<br>
     18 from enthought.traits.ui.api import View, Item<br>
---&gt; 19 from enthought.mayavi.core.ui.api import MayaviScene, MlabSceneModel, \<br>
     20         SceneEditor<br>
     21 from enthought.mayavi import mlab<br>
<br>
ImportError: No module named api<br>
<br>
<br>
This is on ubuntu karmic.  Do I need to run from SVN Enthought for this example?<br>
<br></blockquote></div></div><div><br><br>Yes, the latest mayavi api for qt integration are only in the latest SVN Enthought<br><br> </div><div class="im"><blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">


It would be great if we could have a smaller example illustrating your<br>
problem that didn&#39;t depend on all of Enthought&#39;s machinery, because we<br>
really want to make sure things work OK with Qt.  I&#39;ve tried simpler<br>
tests using matplotlib with qt, and those seem OK so far.<br>
 </blockquote></div><div><br>I tested with only qt and it works.<br><br> </div><div class="im"><blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">
One thing to try:<br>
<br>
1. Start ipython *without* --gui<br>
2. At the ipython prompt, type<br>
gui qt<br>
3. Try to run your script.<br>
 </blockquote><blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">
Then, repeat, but with &#39;gui -a qt&#39; instead.  Let us know if  it<br>
produces any difference at all.<br>
<br></blockquote></div><div><br>No difference.<br> <br></div><div class="im"><blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">
If you have a simpler non-mayavi example, send it  our way.<br>
<br></blockquote></div><div><br>It seems it&#39;s mayavi related, I&#39;m adding the mayavi list to this mail.<br><br>Cheers,<br>Michele.<br> </div><blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">


Thanks for the feedback!<br>
</blockquote></div><br>
<br>_______________________________________________<br>
IPython-dev mailing list<br>
<a href="mailto:IPython-dev@scipy.org">IPython-dev@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/ipython-dev" target="_blank">http://mail.scipy.org/mailman/listinfo/ipython-dev</a><br>
<br></blockquote></div><br><br clear="all"><br>-- <br>Regards,<br>Lakshman<br><a href="http://becomingguru.com">becomingguru.com</a><br><a href="http://lakshmanprasad.com">lakshmanprasad.com</a><br>
</div>