Fernando,<br><br><div class="gmail_quote">On Fri, Oct 22, 2010 at 4:16 PM, Fernando Perez <span dir="ltr">&lt;<a href="http://fperez.net">fperez.net</a>@<a href="http://gmail.com">gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

Hi Jim!<br>
<br>
[ great to hear from you again :) ]<br>
<br></blockquote><div>Same here! </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<br>
I have to run soon and will be offline for a few days, so I wanted to<br>
at least drop a very quick reply to get you going, while I have a<br>
chance for a more detailed discussion.<br>
<div class="im"><br>
On Fri, Oct 22, 2010 at 2:53 PM, Jim Baker &lt;<a href="mailto:jbaker@zyasoft.com">jbaker@zyasoft.com</a>&gt; wrote:<br>
&gt; As of r7164 of Jython, which will be part of 2.5.2rc2 (and hopefully the<br>
&gt; last release candidate for Jython 2.5.2!), we have what looks decent support<br>
&gt; for readline emulation for Jython, sufficient to run a minimally modified<br>
&gt; version of ipython 0.10.1, including colorization (which is not reproduced<br>
&gt; when copied here for whatever reason from my terminal):<br>
<br>
</div>First, this is *great* news.  We&#39;ll do whatever we can from our side<br>
to make the integration easier as we move forward.<br></blockquote><div><br></div><div>Thanks! </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div class="im"><br>
&gt; Create a jython-ipython fork on github, then make it available from PyPI. My<br>
&gt; current plan is to target against the 0.10.1 tag, but if it makes more sense<br>
&gt; to go with 0.11 (especially AST support), then please tell me. More unit<br>
<br>
</div>As to this point, yes, please base any new work you do on the 0.11<br>
tree (master branch on github).  The 0.10 codebase is in minimal<br>
maintenance-only mode, while the 0.11 one is in very active<br>
development and has seen massive refactorings (for the better).  So<br>
that&#39;s the place to build any new ideas on.<br>
<br></blockquote><div><br></div><div>I just tried a checkout of master, however I get the following:</div><div><br></div></div><blockquote class="webkit-indent-blockquote" style="margin: 0 0 0 40px; border: none; padding: 0px;">

<div class="gmail_quote"><div>ImportError: Python Version 2.6 or above is required for IPython.</div></div></blockquote><div class="gmail_quote"><div><br></div><div>Trying a little bit more by disabling that version check, I discovered that at least 2.6&#39;s support of print as a function, instead of a statement, is used. Now Jython 2.6 work kicked off just this week, so hopefully we don&#39;t really need 2.6. Jython 2.5 does have two key 2.6 features that you might be using: 1) full mutable ast support (through the ast module, used by sympy&#39;s support); 2) class decorators. (We also have namedtuple.)</div>

<div><br></div><div>Maybe for Jython this is just a matter of isolating the print function? It doesn&#39;t seem to be used in too many places.</div><div><br></div><div>- Jim</div></div>