i removed the file &quot;/usr/local/bin/ipython-qtconsole&quot;<br>now it is no more generated by the build (i guess fo the missed zmq dep.)<br><br>i downloaded ipython with this line :<br><br> git clone <a href="https://github.com/ipython/ipython.git">https://github.com/ipython/ipython.git</a><br>
<br>(few minutes ago)<br><br>then i tried to reinstall it ... but no lucky<br><br>epi@epinux:~/ipython$ ipython-qtconsole <br>bash: /usr/local/bin/ipython-qtconsole: File o directory non esistente<br><br><br>epi@epinux:~/ipython$ ipython netbook<br>
[TerminalIPythonApp] File not found: u&#39;netbook&#39;<br><br><br>epi@epinux:~/ipython$ ipython<br>Python 2.7.2+ (default, Oct  5 2011, 10:41:47) <br>Type &quot;copyright&quot;, &quot;credits&quot; or &quot;license&quot; for more information.<br>
<br>IPython 0.12.dev -- An enhanced Interactive Python.<br>?         -&gt; Introduction and overview of IPython&#39;s features.<br>%quickref -&gt; Quick reference.<br>help      -&gt; Python&#39;s own help system.<br>object?   -&gt; Details about &#39;object&#39;, use &#39;object??&#39; for extra details.<br>
<br>In [1]: <br><br><br><br><div class="gmail_quote">2011/10/30 Julian Taylor <span dir="ltr">&lt;<a href="mailto:jtaylor.debian@googlemail.com">jtaylor.debian@googlemail.com</a>&gt;</span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div class="im">On 10/30/2011 03:35 PM, massimo di stefano wrote:<br>
&gt; Hi Julian,<br>
&gt;<br>
&gt; i tried to upgrade my local ipython, i checked the version on my distro<br>
&gt;<br>
&gt;<br>
</div><div class="im">&gt;   File<br>
&gt; &quot;/usr/local/lib/python2.7/dist-packages/ipython-0.11-py2.7.egg/IPython/zmq/__init__.py&quot;,<br>
&gt; line 25, in &lt;module&gt;<br>
&gt;     minimum_pyzmq_version, pyzmq_version))<br>
&gt; ImportError: IPython.zmq requires pyzmq &gt;= 2.1.4, but you have 2.1.10<br>
&gt;<br>
&gt;<br>
&gt;<br>
<br>
</div>make sure to install the latest git version.<br>
Especially this file must be the newest:<br>
/usr/local/lib/python2.7/dist-packages/ipython-0.11-py2.7.egg/IPython/zmq/__init__.py<br>
<br>
</blockquote></div><br>