<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#ffffff">
    Em 16-11-2011 10:52, Thomas Kluyver escreveu:<br>
    <blockquote
cite="mid:CAOvn4qj_yhRxYv4o67cCxghttYMKwkOpUB2y5uDceU8A+pQh3g@mail.gmail.com"
      type="cite">
      <div class="gmail_quote">
        <blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt
          0.8ex; border-left: 1px solid rgb(204, 204, 204);
          padding-left: 1ex;">
          <div id=":11t">
            I will soon package and submit IPython 0.10.2 for Maemo 4
            &amp; 5. IPython<br>
            0.11 is more difficult to package for Maemo/MeeGo due to its
            additional<br>
            dependencies.<br>
          </div>
        </blockquote>
        <div><br>
          The basic terminal shell shouldn't have any more dependencies,
          as far as I'm aware. You only need ZMQ etc. if you want to use
          the Qt console or the parallel computing stuff. If it is
          feasible to package 0.11, that would be great - it's a
          significant upgrade from 0.10.x, and I don't think anyone's
          terribly interested in supporting the old code. We're also
          hoping to release 0.12 soon, which will further improve on
          0.11.<br>
        </div>
      </div>
    </blockquote>
    <br>
    &nbsp;&nbsp;&nbsp; I have actually suffered to install IPython 0.11 on Ubuntu 10.04
    64 bits due to the ZMQ dependency. But I will later give IPython
    0.11 a try on MeeGo Harmattan, thanks for the suggestion. But Maemo
    4/5 has Python 2.5 and IPython 0.11 needs at least Python 2.6. <br>
    &nbsp;
    <blockquote
cite="mid:CAOvn4qj_yhRxYv4o67cCxghttYMKwkOpUB2y5uDceU8A+pQh3g@mail.gmail.com"
      type="cite">
      <div class="gmail_quote">
        <blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt
          0.8ex; border-left: 1px solid rgb(204, 204, 204);
          padding-left: 1ex;">
          <div id=":11t"> &nbsp; &nbsp; I have searched and found that IPython for
            Android OS doesn't work<br>
            (there is no libreadline). For iOS there is IPython only
            jail-breaking<br>
            it (Cydia) and following some manual installation steps. No
            IPython for<br>
            Symbian OS. Am I right ?</div>
        </blockquote>
        <div><br>
          It might be possible to use pyrepl (<a moz-do-not-send="true"
            href="http://codespeak.net/pyrepl/">http://codespeak.net/pyrepl/</a>)
          to provide a readline-like interface on android, depending on
          what the terminal there is like.<br>
        </div>
      </div>
    </blockquote>
    <br>
    &nbsp;&nbsp;&nbsp; Thanks for pointing this possible solution.<br>
    <br>
    <blockquote
cite="mid:CAOvn4qj_yhRxYv4o67cCxghttYMKwkOpUB2y5uDceU8A+pQh3g@mail.gmail.com"
      type="cite">
      <div class="gmail_quote">
        <div>Another possibility, if mobile browsers are sufficiently
          advanced, is to access IPython in the browser. Pythonanywhere
          embeds a terminal in a web page: <a moz-do-not-send="true"
            href="http://www.pythonanywhere.com/try-ipython/">http://www.pythonanywhere.com/try-ipython/</a>
          (down at the moment), or there's an in-browser notebook
          interface coming with 0.12. This is probably the only way
          round the restrictions for iOS platforms.<br>
        </div>
      </div>
    </blockquote>
    <br>
    &nbsp;&nbsp;&nbsp; Very interesting this in-browser notebook interface !<br>
    <br>
    &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Thanks,<br>
    <br>
    &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Roberto<br>
    <br>
  </body>
</html>