Just noticed that this was sent to ipython-user not ipython-dev on accident. Sorry for the cross-posting.<div><br></div><div>PTM<br clear="all"><br><div class="gmail_quote">---------- Forwarded message ----------<br><br><div>

Hi, All,</div><div><br></div><div>Before I file an issue ticket, I wanted to make sure that I&#39;m not messing up something on my end…</div><div><br></div><div>When making a plot in IPython Notebook that includes text or a legend in the plotting area that is not a title or axis label causes the figure to lose the axes spines and a host of other information. Here&#39;s a gist to illustrate: <a href="http://nbviewer.ipython.org/3952759/" target="_blank">http://nbviewer.ipython.org/3952759/</a></div>


<div><br></div><div>The first figure doesn&#39;t add anything to the plot and thus displays correctly. The second figure, however, adds a legend, a text box, and labels colored grid points. This figure is not displayed correctly. (I&#39;ve tried all sorts of combinations of the three, and they all cause the display issue.)</div>


<div><br></div><div>I&#39;m using latest dev versions of IPython, Matplotlib, and ZMQ. (This info is included in the notebok.)</div><div><br></div><div>When downloading the notebook as a .py file and running it in IPython normally, the plot is saved just fine. Furthermore, running the script in the IPython Notebook (and including plt.save()), the saved figure is also displayed correctly.</div>


<div><br></div><div><br></div><div>Is this an actual bug or did I mess something up?</div><div><br></div>---<br>Patrick Marsh<br>Ph.D. Candidate / Liaison to the HWT<br>School of Meteorology / University of Oklahoma<br>Cooperative Institute for Mesoscale Meteorological Studies<br>


National Severe Storms Laboratory<br><a href="http://www.patricktmarsh.com/" target="_blank">http://www.patricktmarsh.com</a><br><br>
</div><br></div>