[IPython-user] prompt problem on emacs

Fredrik Svensson svenna01 at gmail.com
Sun Oct 3 14:40:31 CDT 2004


yes,

it seems to work great on linux. another oppertunity to work there
then!

I think that the problem on win is that the communication with 
the ipython/python process run in some kind of undecided-dos 
coding system. I don't know how to switch the coding system
for subprocesses or processes... and I don't know what to change
to (I think to some kind of unicode)

regards fredrik


On Thu, 30 Sep 2004 16:44:51 -0600, Fernando Perez
<fernando.perez at colorado.edu> wrote:
> Hi Fredrik,
> 
> Fredrik Svensson schrieb:
> 
> 
> 
> > I'm trying to use the 0.4 emacs package in emacs 21.3.50 on a Windows XP
> > Seems like the coloring support is broken in my setup. The in prompt
> > is garbled  to something like this:
> >     ^A^BIn [^A^B30^A^B]:^A^B
> > Evrything except the first and the last control sequence is colored
> > green, so there is some kind of coloring support :)
> >
> > The output promt is nowhere to be seen is another problem that I see.
> >
> > And finally the tab-completion of magic commands doen't work...
> >
> >
> > Would appriciate any help that can point me in the right direction
> > to solve my issues....
> 
> Unfortunately I don't have access to Windows, so I'm not sure what the problem
> may be.  Under Unix, the ipython.el mode seems to correctly color the prompts
> always, but users _have_ reported weird behavior with emacs+Windows in the
> past.  Specifically, this summer we had this thread:
> 
> http://www.scipy.net/pipermail/ipython-user/2004-June/000367.html
> 
> Unfortunately, as far as I know the issue went unresolved.  Or perhaps Michael
> did find a solution and can chime in.
> 
> Sorry but this is the best I seem to find.  If you get a solution to your
> problem, it would be great if you can let us know.  It will help others in the
> future to have it documented.
> 
> Regards,
> 
> f
>




More information about the IPython-user mailing list