[IPython-user] heads up - incompatible changes in CVS

Fernando Perez Fernando.Perez at colorado.edu
Fri Apr 8 03:35:41 CDT 2005


Hi all,

If you update CVS, please look at the Changelog.  Two incompatible changes 
were made (for good reasons):

1. pysh users: in your ipythonrc-pysh profile, you MUST:

- add the line
import_all IPython.Extensions.InterpreterExec

- remove the line
execfile pysh.py

Also, delete altogether the file pysh.py from ~/.ipython.  If you had 
additional stuff there, then leave your own stuff, but otherwise remove 
EVERYTHING which came with that file originally.

2. The API for custom tab-completers changed slightly.  I had a bug in it 
(John, I looked more at it, and the state flag really doesn't belong there). 
If you have any custom completers defined, simply remove the state parameter. 
  Custom completers must ONLY take (self,text) as arguments.

Sorry for any trouble this may cause.  I'll reiterate these warnings when this 
gets released for those not using CVS.

Best,

f




More information about the IPython-user mailing list