[IPython-user] Can somebody help me with readline support?

Nathan frizop at yahoo.com
Thu Aug 24 08:50:47 CDT 2006


Alright, so I've been googling for an hour now trying to figure out how to get this done, but I can't for whatever reason get python 2.4 to use the readline library I've installed. Can somebody help me with this?

I've got, 

/usr/local/lib% ls
libhistory.5.1.dylib  libhistory.a          libreadline.5.1.dylib libreadline.a
libhistory.5.dylib    libhistory.dylib      libreadline.5.dylib   libreadline.dylib

/usr/bin/python
/usr/bin/python2.3
/usr/bin/pythonw
/usr/bin/pythonw2.3
/usr/local/bin/python
/usr/local/bin/python2.4
/usr/local/bin/pythonw
/usr/local/bin/pythonw2.4

when I do a 'which python' I get the /usr/bin/python. When I run ipython I get this prompt.
Python 2.4.3 (#1, Mar 30 2006, 11:02:16) 

So I assume it's using the /usr/local/bin version. How can I make /usr/local/bin/python2.4 use the readline librarys I've installed to /usr/local/lib

Thanks in Advance for any help guys.
--Nathan




More information about the IPython-user mailing list