[IPython-user] ipython + visual

sunqiang sunqiang at gmail.com
Tue Feb 28 08:06:46 CST 2006


forgive me for out of topic, but when i send the post before, it doesn't
appear in the maillist. and is it has some relationship ?*
ipython quits after run a wxpython script two times *
the script is very simple.
==================
import wx
app = wx.PySimpleApp()
win = wx.Frame(None, title='Hello World!')
win.Show()
app.MainLoop()* *
==================
i start ipython with  -wthread and run the script times,
when i close the wxapp the second time, ipython quits.

if i start ipython without -wthread, it works well.

is there sth. wrong? thanks in advance.

IPython 0.7.1.fix1 on windows server 2003 sp1.

On 2/28/06, Ville Vainio <vivainio at gmail.com> wrote:
>
> On 2/28/06, Ryan Krauss <ryanlists at gmail.com > wrote:
>
> > I am fairly certain the problem is on the vpython side, I just
> > wondered if there was a way around it.
>
> How does vpython shut itself down, any ideas? os.abort() at least is
> something that shuts ipython down...
>
> --
> Ville Vainio - vivainio.googlepages.com
> vainio.blogspot.com - g[mail | talk]='vivainio'
>
> _______________________________________________
> IPython-user mailing list
> IPython-user at scipy.net
> http://scipy.net/mailman/listinfo/ipython-user
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/ipython-user/attachments/20060228/9da6375e/attachment.html 


More information about the IPython-user mailing list