[IPython-user] MPI and ipython install

Brian Granger ellisonbg.net@gmail....
Thu Dec 4 13:05:13 CST 2008


Philippe,

Sounds like a nice new cluster.

I think the issue here is with your OpenMPI+mpi4py installation, not
with IPython.  To begin debugging this I recommend doing the
following:

1.  Run the mpi4py test suite by doing:

$ cd mpi4py/tests/unittest
$ make all

(you will need to have mpiexec setup to start jobs on your cluster or localhost)

All the tests should run with no seg faults.

2.  If that works, I am not sure what to think - IPython should work
as well.  If this is the case, let me know and we can try to look at
this further.

3.  If that doesn't work, then you need to debug your OpenMPI+mpi4py install.

Here is what I would do:

* Install the latest OpenMPI (1.2.8).  A lot has changed since 1.2.2.

* Test the OpenMPI install with a single hello world MPI program in C
(google for that).

* If all that works, then install mpi4py making sure that OpenMPI's
mpirun command is on your path.  Then mpi4py will pick that up.  Also,
make sure you are using the latest stable release of mpi4py (0.6) and
then rerun the test suite.

I am also forwarding this email to Lisandro Dalcin, the author of
mpi4py.  He may have ideas about what is going wrong here.

Cheers,

Brian

> for mpi4py we just use the module provided by clustervision
> openmpi/gcc/64/1.2.2
>
> and then a :
> for mpi4py
> $python setup.py install
>
> for ipython
> $python setup.py install
>
> followed by
> mpirun -n 4 ipengine --mpi=mpi4py
> [node005:22031] *** Process received signal ***
> [node005:22031] Signal: Segmentation fault (11)
> [node005:22031] Signal code: Address not mapped (1)
> [node005:22031] Failing at address: 0x1
> [node005:22031] [ 0] /lib64/tls/libpthread.so.0 [0x33b840c4f0]
> [node005:22031] [ 1] /lib64/tls/libc.so.6(strcmp+0) [0x33b7770240]
> [node005:22031]
> [ 2] /cvos/shared/apps/openmpi/gcc/64/1.2.2/lib64/openmpi/mca_pls_rsh.so(orte_pls_rsh_launch+0x243)
> [0x2a97335c53] [node005:22031]
> [ 3] /cvos/shared/apps/openmpi/gcc/64/1.2.2/lib64/openmpi/mca_rmgr_urm.so
> [0x2a97748a9e] [node005:22031] [ 4] mpirun(orterun+0x3ec) [0x402d44]
> [node005:22031] [ 5] mpirun(main+0x1b) [0x402953] [node005:22031]
> [ 6] /lib64/tls/libc.so.6(__libc_start_main+0xdb) [0x33b771c3fb]
> [node005:22031] [ 7] mpirun [0x4028aa] [node005:22031] *** End of error
> message *** Segmentation fault
>
> any clue ?
>
>
> --
> Philippe BAUCOUR
> 2 rue de la poissonnerie
> 90000 Belfort
> FRANCE
> Tel :  +33 (0)3.84.28.90.34
> _______________________________________________
> IPython-user mailing list
> IPython-user@scipy.org
> http://lists.ipython.scipy.org/mailman/listinfo/ipython-user
>


More information about the IPython-user mailing list