[IPython-user] Readline works in 2.3, why not in 2.4

Mike Winter (miwinter) miwinter@cisco....
Thu Jun 19 12:26:31 CDT 2008


cp /usr/lib/python2.3/lib-dynload/readline.so
venv/lib/python2.4/lib-dynload/ fixes this. But a flag to build it in
2.4.5 would be better! 

-----Original Message-----
From: ipython-user-bounces@scipy.org
[mailto:ipython-user-bounces@scipy.org] On Behalf Of Mike Winter
(miwinter)
Sent: Thursday, June 19, 2008 10:20 AM
To: ipython-user@scipy.org
Subject: [IPython-user] Readline works in 2.3, why not in 2.4

Is there somethin special required in my virtualenv install for ipython
to work correctly?

$ type ipython
ipython is hashed (/home/miwinter/sandbox/waas/test/venv/bin/ipython)

$ ipython
WARNING: Readline services not available on this platform.
WARNING: The auto-indent feature requires the readline library Python
2.4.5 (#5, Jun 18 2008, 21:11:59)

In [1]: ^D

$ type python
python is /usr/bin/python
$ ipython
Python 2.3.5 (#1, Apr  6 2005, 14:32:42) Type "copyright", "credits" or
"license" for more information.

IPython 0.6.13 -- An enhanced Interactive Python.
?       -> Introduction to IPython's features.
%magic  -> Information about IPython's 'magic' % functions.
help    -> Python's own help system.
object? -> Details about 'object'. ?object also works, ?? prints more.

In [1]:
_______________________________________________
IPython-user mailing list
IPython-user@scipy.org
http://lists.ipython.scipy.org/mailman/listinfo/ipython-user


More information about the IPython-user mailing list