[IPython-User] [IPython-user] Ipython sys.path and import module failure

Brian Granger ellisonbg@gmail....
Mon Dec 27 11:48:38 CST 2010


This sounds like an issue with the install of IPython.  Some questions:

* How did you install IPython?
* What version of IPython?
* What do you get when you do:

$ ipython

In [1]:  import IPython; print IPython.__file__

Does that location match where you expect IPython to be installed?

* What version of Python are you using?  Are there multiple Python's
on your path?

Cheers,

Brian

On Tue, Nov 30, 2010 at 8:21 AM, Charles Miglietti
<charles.miglietti@yahoo.fr> wrote:
>
> Hi,
>
> I have an issue importing new modules using ipython. When I use the normal
> python interpreter some modules are loaded correctly but when I try to
> import them in ipython it fails. These modules were installed with
> easy_install or with .egg.
> The sys.path array is different from python interpreter to ipython and I
> think this is the issue. My question is why is this different and how can I
> make things working with ipython ?
> I am on Mac OS 10.6 Snow Leopard.
>
> Thanks
>
>
> --
> View this message in context: http://old.nabble.com/Ipython-sys.path-and-import-module-failure-tp30341123p30341123.html
> Sent from the IPython - User mailing list archive at Nabble.com.
>
> _______________________________________________
> IPython-User mailing list
> IPython-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user
>



-- 
Brian E. Granger, Ph.D.
Assistant Professor of Physics
Cal Poly State University, San Luis Obispo
bgranger@calpoly.edu
ellisonbg@gmail.com


More information about the IPython-User mailing list