[IPython-User] Specifying prompt for qtconsole at command line

MinRK benjaminrk@gmail....
Sat Aug 6 16:15:51 CDT 2011


On Sat, Aug 6, 2011 at 14:12, Arlindo da Silva <dasilva@alum.mit.edu> wrote:

> On Sat, Aug 6, 2011 at 5:08 PM, Arlindo da Silva <dasilva@alum.mit.edu>wrote:
>
>> On Sat, Aug 6, 2011 at 12:29 PM, Min RK <benjaminrk@gmail.com> wrote:
>>
>>> Command-line args are prefixed with '--', so you want:
>>> % ipython-qtconsole --IPythonWidget.in_prompt='xxx> '
>>>
>>> There are zero options in IPython that cannot be set from the
>>> command-line.
>>>
>>> Note that this particular prompt won't work of you are using 0.11 and not
>>> trunk, because the released version doesn't allow prompts that don't have
>>> '%i' for the prompt number. This has been fixed.
>>>
>>>
>> Thank you, I think I solved the mystery. I've been developing under EPD
>> 7.1-1 which uses 0.11rc1. I got it working once I updated to EPD-7.1-2 which
>> has the actual 0.11 (not rc1) and had the "%i" in it.  There are subtle
>> changes going from 0.11rc1 to 0.11. For one, the command line syntax for
>> properties now has the "--" in front of it, consistent with the
>> documentation.  Probably some bugs have been fixed as well.
>>
>>
>
> One last thing. Any good reason why "--no-banner" is not implemented for
> the qtconsole?
>

No, there isn't.  The QtConsole Application was originally written entirely
without configuration support, which was added not long before cutting 0.11,
so some things were just overlooked.


>
>    Arlindo
>
> --
> Arlindo da Silva
> dasilva@alum.mit.edu
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20110806/14f3554f/attachment.html 


More information about the IPython-User mailing list