[IPython-User] Errors in ipython 0.11 using python 3.2.1

Aaron Meurer asmeurer@gmail....
Fri Aug 12 11:04:57 CDT 2011


Why don't you upload that file to pypi (and mark it as Python 3)?  I
think if you do that at least pip-3.2 should be smart enough to use
it.

Aaron Meurer

On Fri, Aug 12, 2011 at 9:41 AM, Thomas Kluyver <takowl@gmail.com> wrote:
> On 12 August 2011 16:22, Maarten Derickx <m.derickx.student@gmail.com>
> wrote:
>>
>> I guess that as soon as it becomes possible to easy_install ipython
>> for python3 then it will all become easier because then easy_install
>> will put the executables like ipython3 and ipcluster3 etc in
>> /urs/local/bin. Because that is what happens now on OS X as shown
>> below:
>
> Interesting - on Linux, doing "python setup.py install" seems to put those
> scripts in /usr/local/bin. You might want to try easy_install-ing the Python
> 3 egg:
> http://archive.ipython.org/release/0.11/py3/ipython-0.11-py3.2.egg
>
> (Note that you'll need a Python 3 easy_install or pip - on my system, these
> are called easy_install3 and pip-3.2)
>
> Thomas
>


More information about the IPython-User mailing list