[IPython-User] Errors in ipython 0.11 using python 3.2.1

Thomas Kluyver takowl@gmail....
Fri Aug 12 11:13:22 CDT 2011


On 12 August 2011 17:04, Aaron Meurer <asmeurer@gmail.com> wrote:

> Why don't you upload that file to pypi (and mark it as Python 3)?  I
> think if you do that at least pip-3.2 should be smart enough to use
> it.
>

We asked pypi people about that, and the position seemed to be that we
couldn't have more than one source distribution under the same name. It's
not a major concern, because the plan is to have the next version work with
Python 3 by running 2to3 as part of the build process. I've done some work
towards this already:

https://github.com/ipython/ipython/pull/663
https://github.com/takluyver/ipython/tree/py3compat

If you want to try this, note that at present, you need to do "python3
setup3.py install" to install in Python 3 (I'll fix that soon). Also, use of
a virtualenv is highly recommended, because it's still very much a work in
progress. "virtualenv -p python3 ipy-2to3" should do the trick.

Thanks,
Thomas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20110812/703fdf34/attachment.html 


More information about the IPython-User mailing list