[IPython-User] figure copy/paste doesn't work on MacOS X with OpenOffice

MinRK benjaminrk@gmail....
Sun Aug 21 16:26:56 CDT 2011


On Sun, Aug 21, 2011 at 13:51, Fernando Perez <fperez.net@gmail.com> wrote:
>
> Hi Chris,
>
> On Sun, Aug 21, 2011 at 1:46 PM, Chris Withers <chris@simplistix.co.uk> wrote:
> > I tried to copy (selected the plot by dragging across it, then tried
> > both Ctrl-C and right-click->copy image) a plot from iPython's inline
> > mode to OpenOffice.org 3.x, nothing happened.
> >
> > What am I doing wrong?
> >

I'm not sure.  I would doubt that the select + cmd-C would work (copy
is cmd-C on OSX, not ctrl-C), since you would be selecting the HTML
context of the image, not the image itself.

right-click->copy image does seem work for me. I successfully pasted
into Chrome, Preview, and Photoshop.  After you copy, can you create a
New Document from Clipboard in Preview (cmd-N)?  Maybe it's OpenOffice
that's having a hard time.

I am using the PySide binary from
http://developer.qt.nokia.com/wiki/PySide_Binaries_MacOSX on System
Python 2.7.1 on 10.7.1

-MinRK

>
> not sure.  On ubuntu 10.10, I just tried 'copy image' from the menu,
> then in openoffice 3.x I did Ctrl-V, and it worked.  I got the png
> which isn't very high resolution, but it did work...
>
> What platform are you on?
>
> Cheers,
>
> f
> _______________________________________________
> IPython-User mailing list
> IPython-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user


More information about the IPython-User mailing list