[IPython-User] Problem with matplotlib when running within IPython

Brian Granger ellisonbg@gmail....
Tue Feb 8 16:36:26 CST 2011


Jorge,

Can you give more details about:

* OS
* matplotlib backend
* Python version
* IPython version

Cheers,

Brian

On Tue, Feb 8, 2011 at 2:56 AM, Jorge Scandaliaris
<jorgesmbox-ml@yahoo.es> wrote:
> Hi,
>
> In the last few days I've been troubleshooting a problem with a script using
> matplotlib (mpl). The script relies on mpl event handling mechanisms to allow
> for some interactions (mouse and keys). I've been adding and modifying to this
> script for a long time.
> This week I wanted to add some new functionality to it, but started having
> problems with the interactive part, i.e. I couldn't interact with neither the
> mouse nor the keys. Long story short: When the script draws a small number of
> elements (circles, ellipses) everything works as expected. Upon increasing the
> number of elements, the (custom, mpl inbuilt interactions still work) event
> handling stops working. Now the reason I am posting this here is because if I
> run the script directly from python, I don't see the problem.
> Would anyone have any clue about what could be happening? I don't know how to
> debug this either, so any hints will be appreciated.
>
> Thanks,
>
> jorges
>
> _______________________________________________
> IPython-User mailing list
> IPython-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user
>



-- 
Brian E. Granger, Ph.D.
Assistant Professor of Physics
Cal Poly State University, San Luis Obispo
bgranger@calpoly.edu
ellisonbg@gmail.com


More information about the IPython-User mailing list