[IPython-User] PyZMQ 2.1.10

MinRK benjaminrk@gmail....
Thu Oct 13 20:05:23 CDT 2011


ZeroMQ cut 2.1.10 last week, and I followed suit today, cutting PyZMQ 2.1.10.

The principal relevance of this for IPython is that IPython 0.11 uses
a string comparison for checking the pyzmq version, but this obviously
doesn't work once you get into double digits. This was fixed in master
quite a while ago, so updating to IPython master (or using pyzmq 2.1.9
or dev) will avoid the issue. But the situation is that IPython's zmq
code (parallel and qtconsole) will raise ImportErrors with pyzmq
2.1.10.

If you must use IPython 0.11 and a bdist of pyzmq, you can force pyzmq
to install 2.1.9 with `easy_install pyzmq==2.1.9`.

-MinRK


More information about the IPython-User mailing list