[IPython-User] Ipython - dev on debian sid (zmq suppport)

massimo di stefano massimodisasha@gmail....
Sun Oct 30 06:53:53 CDT 2011


Hi All,

i'm tring to install Ipython (git version) on my linux debian (sid 64 bit)
unlucky i'm not able to add the zmq support,
because of a mismatch in the dependence.
the message i had is about the zmq version :

IPython.zmq requires pyzmq >= 2.1.4, but you have 2.1.10

i guess there is something wrong ...  2.1.10 should be > 2.1.4 , is it ?

the configure script return the same worning :

epi@epinux:~/ipython$ python setup.py build
============================================================================
BUILDING IPYTHON
                python: 2.7.2+ (default, Oct  5 2011, 10:41:47)  [GCC 4.6.1]
              platform: linux2

OPTIONAL DEPENDENCIES
                sphinx: 1.1
              pygments: 1.4
/usr/local/lib/python2.7/dist-packages/nose-1.1.2-py2.7.egg/nose/plugins/manager.py:405:
UserWarning: Module argparse was already imported from
/usr/lib/python2.7/argparse.pyc, but /usr/lib/python2.7/dist-packages is
being added to sys.path
  import pkg_resources
                  nose: 1.1.2
               pexpect: 2.3
                 pyzmq: no (have 2.1.10, but require >= 2.1.4 for qtconsole
                        and parallel computing capabilities)
              readline: yes
running build
running build_py
creating build


Please, have you any clue on what's going wrong ?

Many thanks for any help!
--Massimo.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20111030/79406b91/attachment.html 


More information about the IPython-User mailing list