[IPython-User] troubleshooting ipcluster

MinRK benjaminrk@gmail....
Wed Jul 11 12:42:31 CDT 2012


What is the stdout/err of the controller and engine jobs?

On Wed, Jul 11, 2012 at 6:03 PM, Robert Nishihara
<robertnishihara@gmail.com> wrote:
> My cluster recently upgraded to IPython 0.13. Now, when I run
>
>     ipcluster start -n 3 --profile=sge
>
> the controller and engines get submitted to the queue, but the terminate
> immediately after starting. However, the output looks normal
>
>     2012-07-11 11:56:27,531.531 [IPClusterStart] Using existing profile dir:
> u'/home/robert/.ipython/profile_sge'
>     2012-07-11 11:56:27.566 [IPClusterStart] Starting ipcluster with
> [daemon=False]
>     2012-07-11 11:56:27.570 [IPClusterStart] Creating pid file:
> /home/robert/.ipython/profile_sge/pid/ipcluster.pid
>     2012-07-11 11:56:27.573 [IPClusterStart] Starting Controller with
> SGEControllerLauncher
>     2012-07-11 11:56:27.723 [IPClusterStart] Job submitted with job id:
> '2088'
>     2012-07-11 11:56:28.568 [IPClusterStart] Starting 3 Engines with
> SGEEngineSetLauncher
>     2012-07-11 11:56:28.645 [IPClusterStart] Job submitted with job id:
> '2089'
>     2012-07-11 11:56:58.647 [IPClusterStart] Engines appear to have started
> successfully
>
> Is there a good way to troubleshoot this? The --debug flag doesn't seem to
> give me any useful information.
>
> -Robert
>
> _______________________________________________
> IPython-User mailing list
> IPython-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user
>


More information about the IPython-User mailing list