[IPython-User] Installing ipython dependencies

Felix Patzelt felix@neuro.uni-bremen...
Fri Jul 20 05:06:21 CDT 2012


Hi,

can anyone give me tips on installing the main ipython dependencies?

easy_install ipython[zmq,qtconsole,notebook,test]

fails:

pkg_resources.UnknownExtra: ipython 0.13 has no such extra feature
'qtconsole')

Further, easy_install ipython[zmq] also fails because distribute only tries
to install pyzmq and requires zmq to be installed first. Installing zmq
from source fails, because it can't find uuid-devel. It's all a huge
pain.

Installing ipython from source doesn't include the dependencies. On my
Mac, I just installed everything via macports which takes very very
long, but the packages are reasonably up to date. However, my workgroups
desktop computers and cluster nodes run scientific linux 6 - therefore
everything is years out of date.

Is there any other way to get the ipython dependencies in my user
directory other than installing every single one manually from source? I
already installed python2.7.3 from source. I also installed the latest
numpy, scipy and matplotlib versions as well as ipython 0.13 without the
optional dependencies using distutils. These packages work fine except
for ipython complaining about missing SQlite. However, I would like to
be able to use the qtconsole and start ipython engines.

best, 
Felix


More information about the IPython-User mailing list