[IPython-User] ipcluster in ssh mode in ipython 0.13

MinRK benjaminrk@gmail....
Tue Jul 24 20:17:22 CDT 2012


The SGE issue is fixed in master, and a workaround is described in Issue
#2171 <https://github.com/ipython/ipython/issues/2171>.

On Tue, Jul 24, 2012 at 5:44 PM, Robert Nishihara <robertnishihara@gmail.com>
wrote:
> <
http://lists.ipython.scipy.org/pipermail/ipython-user/2012-July/010619.html>
> for reference.
>
>
> On Tue, Jul 24, 2012 at 5:42 PM, Robert Nishihara
> <robertnishihara@gmail.com> wrote:
>>
>> I am also interested in the answer to this question.
>>
>> I think I am running into the same problem (except I am using SGE) when I
>> use IPython 0.13. It works in IPython 0.12.
>>
>>
>> On Thu, Jul 19, 2012 at 1:39 AM, M. Wimmer <wimmer.mike@gmail.com> wrote:
>>>
>>> Thanks for the quick reply!
>>>
>>> > (or similar)PR #2163 (one-character patch) should fix it.  Can you
>>> > confirm
>>> > that?
>>>
>>> I tried this, and it certainly fixes the problem with the profile
>>> directory
>>> (i.e. the scp-commands work now).
>>>
>>> However I have still problems with the engines not being launched due to
>>> a
>>> syntax error (only the relevant part, and I add -vvv to ssh):
>>>
>>> 2012-07-19 10:29:34.700 [IPClusterStart] debug1: Sending command:
>>>  /usr/bin/python -c from IPython.parallel.apps.ipengineapp import
>>>  launch_new_instance; launch_new_instance() --profile-dir
>>>  .ipython/profile_ssh --log-to-file --log-level=20
>>> 2012-07-19 10:29:34.763 [IPClusterStart] bash: -c: line 0: syntax error
>>> near
>>>  unexpected token `--profile-dir'
>>> 2012-07-19 10:29:34.764 [IPClusterStart] bash: -c: line 0:
>>> `/usr/bin/python
>>>  -c from IPython.parallel.apps.ipengineapp import launch_new_instance;
>>>  launch_new_instance() --profile-dir .ipython/profile_ssh --log-to-file
>>>  --log-level=20'
>>>
>>> It seems to me that there are some quotation marks missing around `from
>>> ...
>>> launch_new_instance()`? (I have to admit that quoting always confuses
me)
>>>
>>> Indeed, if I add to ipcluster_config.py
>>>
>>>  c.SSHEngineSetLauncher.engine_cmd = ['/usr/bin/python', '-c', '\"from
>>>   IPython.parallel.apps.ipengineapp import launch_new_instance;
>>>   launch_new_instance()\"']
>>>
>>> the syntax error is solved.
>>>
>>> Unfortunately, the cluster still does not start, as the engines simply
>>> stop
>>> within two seconds or so. I'm still investigating this, but in any case
>>> it
>>> would be nice if you could have a look into what I wrote above.
>>>
>>> All the best,
>>>
>>> Michael
>>>
>>>
>>> _______________________________________________
>>> IPython-User mailing list
>>> IPython-User@scipy.org
>>> http://mail.scipy.org/mailman/listinfo/ipython-user
>>
>>
>
>
> _______________________________________________
> IPython-User mailing list
> IPython-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20120724/e4d65875/attachment-0002.html 


More information about the IPython-User mailing list