[IPython-User] Rendering Bug in Notebook?

Patrick Marsh patrickmarshwx@gmail....
Thu Oct 25 09:18:37 CDT 2012


Hi, All,

Before I file an issue ticket, I wanted to make sure that I'm not messing
up something on my end…

When making a plot in IPython Notebook that includes text or a legend in
the plotting area that is not a title or axis label causes the figure to
lose the axes spines and a host of other information. Here's a gist to
illustrate: http://nbviewer.ipython.org/3952759/

The first figure doesn't add anything to the plot and thus displays
correctly. The second figure, however, adds a legend, a text box, and
labels colored grid points. This figure is not displayed correctly. (I've
tried all sorts of combinations of the three, and they all cause the
display issue.)

I'm using latest dev versions of IPython, Matplotlib, and ZMQ. (This info
is included in the notebok.)

When downloading the notebook as a .py file and running it in IPython
normally, the plot is saved just fine. Furthermore, running the script in
the IPython Notebook (and including plt.save()), the saved figure is also
displayed correctly.


Is this an actual bug or did I mess something up?

---
Patrick Marsh
Ph.D. Candidate / Liaison to the HWT
School of Meteorology / University of Oklahoma
Cooperative Institute for Mesoscale Meteorological Studies
National Severe Storms Laboratory
http://www.patricktmarsh.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20121025/9d2deb9e/attachment.html 


More information about the IPython-User mailing list