[IPython-User] Help installing master JS dependencies? please

Thomas Kluyver takowl@gmail....
Sat Aug 31 12:00:40 CDT 2013


It's a bug in Github/git: tarballs don't include git subrepos, so if you
install IPython from a Github tarball, it won't work. If you want to run
IPython from master, for now you'll need to git clone the repo.


On 31 August 2013 08:33, Tom Brander <tombrander@tombrander.com> wrote:

> I was having issues with NB convert, in Ipython 1.0, (which was running
> fine elsewise) I figured I'd just install master so I ran the following on
> Ubuntu 12.10
>
> sudo pip install https://github.com/ipython/ipython/tarball/master
>
> which appeared successful
> but when starting the notebook I got
> WARNING:root:404 GET
> /static/components/jquery-ui/themes/smoothness/jquery-ui.min.css
> (127.0.0.1) 0.34ms
> WARNING:root:404 GET /static/components/jquery/jquery.min.js (127.0.0.1)
> 0.19ms
> WARNING:root:404 GET
> /static/components/bootstrap/bootstrap/js/bootstrap.min.js (127.0.0.1)
> 0.30ms
> WARNING:root:404 GET /static/components/requirejs/require.js (127.0.0.1)
> 0.55ms
> WARNING:root:404 GET
> /static/components/jquery-ui/ui/minified/jquery-ui.min.js (127.0.0.1) 0.41ms
> WARNING:root:404 GET /static/components/requirejs/require.js (127.0.0.1)
> 0.29ms
> WARNING:root:404 GET
> /static/components/bootstrap/bootstrap/js/bootstrap.min.js (127.0.0.1)
> 0.37ms
> WARNING:root:404 GET /static/components/jquery/jquery.min.js (127.0.0.1)
> 0.36ms
> WARNING:root:404 GET
> /static/components/jquery-ui/ui/minified/jquery-ui.min.js (127.0.0.1) 0.36ms
> WARNING:root:404 GET
> /static/components/jquery-ui/themes/smoothness/jquery-ui.min.css
> (127.0.0.1) 0.29ms
> WARNING:root:404 GET /static/components/requirejs/require.js (127.0.0.1)
> 0.26ms
> WARNING:root:404 GET
> /static/components/bootstrap/bootstrap/js/bootstrap.min.js (127.0.0.1)
> 0.28ms
> WARNING:root:404 GET /static/components/requirejs/require.js (127.0.0.1)
> 0.44ms
> WARNING:root:404 GET
> /static/components/bootstrap/bootstrap/js/bootstrap.min.js (127.0.0.1)
> 0.39ms
>
> So I need to install the dependencies, I'm not so swooft with pip so can
> someone tell me where to go to run the right commands?
>
> I see the docs that say that I need to update and sggest pip install -e
> .[notebook] but I don't think I am executing that in the right spot??
>
> tom@tom-sam:~$ sudo pip install -e .[notebook]
> Directory '.' is not installable. File 'setup.py' not found.
> Storing complete log in /home/tom/.pip/pip.log
>
> I'm dead in the water at the moment so help much appreciated...
>
> For some reason my earlier message to the list re nb convert never got
> released??
>
>
>
> --
> Tom Brander
> http://tombrander.com -Real Estate
> http://oswco.com -Open Software
> 3763 West Jackson Blvd.
> Birmingham, AL 35213
> Phone 205-267-1089
> @dartdog
>
>
> _______________________________________________
> IPython-User mailing list
> IPython-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20130831/f889502e/attachment.html 


More information about the IPython-User mailing list