[IPython-User] numerical inaccuracy on osx (notebook)

epi massimodisasha@gmail....
Fri Jun 28 12:22:59 CDT 2013


Hi Michael,

i removed only the "IPython" related files :)
and "temporary" renamed the system numpy (just in case it was a peoblem)
now i restored everything .. (hopefully)
i only have problems with pip that tries to use the system python as install location
 .. but i guess it is a path issue and i need to put the /usr/local/share/python on top in order to use the brew pip

thanks for the advise!


On Jun 28, 2013, at 1:15 PM, K.-Michael Aye <kmichael.aye@gmail.com> wrote:

> On 2013-06-24 18:09:21 +0000, epi said:
> 
>> Matthias,
>> 
>> i removed "all" the ipython installation i found on my system (system 
>> python, brew python)
> 
> Epi,
> 
> Be prepared for some problems to appear after having removed the system 
> python, because some of OSX system utilities use the system python for 
> OS tasks! (I don't know which ones, but I am pretty sure that's true)
> 
> Michael
> 
> 
>> 
>> then i reinstalled ipython with pip  (pip install -U ipython)
>> 
>> which ipython
>> /usr/local/share/python/ipython
>> 
>> ipython --version
>> 0.13.2
>> 
>> 
>> testing in the notebook  the lines :
>> 
>> import numpy as np
>> url='http://www.cdc.noaa.gov/Correlation/amon.us.long.data'
>> data = np.genfromtxt(url, skip_header=1, skip_footer=4)
>> 
>> data[:, 1:][0]
>> 
>> array([ 0.22 ,  0.153,  0.224,  0.143,  0.196,  0.218,  0.232,  0.209,
>>        0.276,  0.126,  0.136,  0.23 ])
>> 
>> from the url :   http://www.cdc.noaa.gov/Correlation/amon.us.long.data
>> 
>> the first row is :
>> 
>> 1856    0.220    0.153    0.225    0.144    0.196    0.219    0.232    
>> 0.209    0.276    0.126    0.137    0.231
>> 
>> 
>> I think the problem is in the notebook + bumpy/pylab  can be possible ?
>> because in the notebook the pandas example work just fine (same results 
>> between notebook and shell/qtconsole)
>> or something related to my locale / system profiles / ipython config ?
>> 
>> 
>> 
>> i tried to open the qtconsole from inside the notebook "  %qtconsole magic "
>> and i got the same problem.
>> 
>> attached a screenshot [1]
>> on the left the ipython shell and qt console running from the bash command line
>> on the right the notebook and qt console running from the qtconsole magic
>> 
>> [1] http://geofemengineering.it/logs/test_np.png
>> 
>> 
>> Il giorno 24/giu/2013, alle ore 13:09, Matthias BUSSONNIER 
>> <bussonniermatthias@gmail.com> ha scritto:
>> 
>>> 
>>> Le 24 juin 2013 à 19:00, epi a écrit :
>>> 
>>>> Hi Matthias,
>>> 
>>> Hi Massimo,>>>>> i do not have EPD/ANACONDA installed.
>>>> i'm  running homebrew python with ipython installed from source (GIT master)
>>> 
>>> Does the same happened if you start qtconsole from the notebook with 
>>> the %qtconsole magic ?
>>> I'm really astonished about how qtconsole  and notebook could differ.
>>> -- 
>>> Matthias
>>> 
>>> _______________________________________________
>>> IPython-User mailing list
>>> IPython-User@scipy.org
>>> http://mail.scipy.org/mailman/listinfo/ipython-user
> 
> 
> 
> _______________________________________________
> IPython-User mailing list
> IPython-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user



More information about the IPython-User mailing list