[IPython-User] cannot run ipython dev using python3 from GIT source?

Thomas Kluyver takowl@gmail....
Wed Mar 6 08:56:55 CST 2013


On 6 March 2013 14:43, Dennis Daniels <dennisgdaniels@gmail.com> wrote:

> The errors that I received on TRYING to run ipython dev using Python3.2.x
> appears to confirm that it is not possible to run ipython 1.0 dev pulled
> from GIT using python3.2x.
>

It's perfectly possible, you just have to install it (python3 setup.py
install). There's a step built into the setup that runs 2to3 on the code.

(That SO question asks about using 'setup.py develop', which doesn't run
the installation process, so it won't work on Python 3)

We have regular tests (ShiningPanda & Travis CI) that include 3.2 and 3.3,
so we'd soon find out if something got broken.

Thomas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20130306/705e8114/attachment.html 


More information about the IPython-User mailing list