[IPython-User] resolved: I want to use Ipython dev notebook but Ipython dev1.0 (git pull 11MAR) is NOT seeing tornado and a q re: docs

Dennis Daniels dennisgdaniels@gmail....
Mon Mar 11 12:38:09 CDT 2013


Thanks Thomas!
I did get it sorted out.
Here's the vid
http://www.youtube.com/watch?v=RJPnOpNsN58
and here's the doc I wrote while getting it working!
https://docs.google.com/document/d/1HY6pwTMGwb7UJ1XQ_eRwbMknrMJgXurpzkV4vgDO1X0/edit?usp=sharing

Again, thanks
Dennis


>    1. I want to use Ipython dev notebook but Ipython dev1.0 (git
>       pull 11MAR) is NOT seeing tornado and a q re: docs (Dennis Daniels)
>    2. Re: I want to use Ipython dev notebook but Ipython dev1.0
>       (git pull 11MAR) is NOT seeing tornado and a q re: docs
>       (Thomas Kluyver)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 11 Mar 2013 13:44:38 +0200
> From: Dennis Daniels <dennisgdaniels@gmail.com>
> Subject: [IPython-User] I want to use Ipython dev notebook but Ipython
>         dev1.0 (git pull 11MAR) is NOT seeing tornado and a q re: docs
> To: ipython-user@scipy.org
> Message-ID:
>         <CAMq8djO0aRf_Wvd0Q_+i+7AYjQXtMrCpMkBBKscMM7vM7fz6Aw@mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
>
> You can see my efforts here to get ipython notebook to work:
> http://www.youtube.com/watch?v=29qDqPl2LDo&feature=youtu.be
>
> -------
> I want to use Ipython dev notebook but Ipython dev1.0 (git pull 11MAR)
> is NOT seeing tornado.
>
> Ipython3 works fine but I want to use the notebook.
>
> installed pip
> sudo apt-get install python-pip
>
> installed tornado
> sudo pip install tornado
>
>
> ipython3 notebook =fail ImportError: The IPython Notebook requires
> tornado >= 2.1.0
>
>
> ipython notebook=fail ImportError: The IPython Notebook requires
> tornado >= 2.1.0
>
>
> And I want to run notebooks with ipython3.
>
>
> thank you
> Dennis
>
> p.s.
> Any chance of getting
> http://ipython.org/ipython-doc/dev/install/install.html#installing-the-development-version
> stripped down to all commands necessary to get a fully functional
> Ipython dev (notebook, qt, etc.) set up with 10-15 lines or less?
>
>
> ------------------------------
>
> Message: 2
> Date: Mon, 11 Mar 2013 12:07:39 +0000
> From: Thomas Kluyver <takowl@gmail.com>
> Subject: Re: [IPython-User] I want to use Ipython dev notebook but
>         Ipython dev1.0 (git pull 11MAR) is NOT seeing tornado and a q re: docs
> To: "Discussions about using IPython. http://ipython.org"
>         <ipython-user@scipy.org>
> Message-ID:
>         <CAOvn4qiTq=kH4UFmia+L5aD8qhyM33Cmxx+eqLb2UVUOz+O=iw@mail.gmail.com>
> Content-Type: text/plain; charset="iso-8859-1"
>
> On 11 March 2013 11:44, Dennis Daniels <dennisgdaniels@gmail.com> wrote:
>
>> installed pip
>> sudo apt-get install python-pip
>>
>> installed tornado
>> sudo pip install tornado
>
>
> That pip will be running on Python 2, so tornado is also getting installed
> for Python 2. Packages have to be installed separately for Python 3.
>
> If you're using an Ubuntu based distro, try this:
>
> sudo apt-add-repository ppa:jtaylor/ipython-dev
> sudo apt-get update
> sudo apt-get install ipython3-notebook
>
> That takes care of dependencies, and the PPA is automatically updated every
> day.
>
> Thomas
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20130311/b80f5df4/attachment-0001.html
>
> ------------------------------
>
> _______________________________________________
> IPython-User mailing list
> IPython-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user
>
>
> End of IPython-User Digest, Vol 113, Issue 15
> *********************************************


More information about the IPython-User mailing list