[IPython-User] Ipython qtconsole error

Wim R. Cardoen wcardoen@gmail....
Tue Mar 12 18:17:36 CDT 2013


Hello,

I installed version IPython 0.13.1 from source after
installing the following packages (from source as well):
Qt 4.8.4
sip: 4.14.4
PyQt4: 4.10
pyzmq: 2.2.0.1
pygments: 1.6
tornado: 2.4.1
mathjax

The commands 'Ipython console', 'Ipython notebook' work well.
When I invoke 'Ipython qtconsole' I obtain the following error:

--------------------------------------------------------------------------------------------------------------------------------------------------
ipython qtconsole
Traceback (most recent call last):
  File "/wim/pkg/python/2.7.3/bin/ipython", line 7, in <module>
    launch_new_instance()
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py",
line 388, in launch_new_instance
    app.initialize()
  File "<string>", line 2, in initialize
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py",
line 84, in catch_config_error
    return method(app, *args, **kwargs)
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py",
line 313, in initialize
    super(TerminalIPythonApp, self).initialize(argv)
  File "<string>", line 2, in initialize
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py",
line 84, in catch_config_error
    return method(app, *args, **kwargs)
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/core/application.py",
line 325, in initialize
    self.parse_command_line(argv)
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py",
line 308, in parse_command_line
    return super(TerminalIPythonApp, self).parse_command_line(argv)
  File "<string>", line 2, in parse_command_line
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py",
line 84, in catch_config_error
    return method(app, *args, **kwargs)
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py",
line 420, in parse_command_line
    return self.initialize_subcommand(subc, subargv)
  File "<string>", line 2, in initialize_subcommand
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py",
line 84, in catch_config_error
    return method(app, *args, **kwargs)
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py",
line 352, in initialize_subcommand
    subapp = import_item(subapp)
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/utils/importstring.py",
line 40, in import_item
    module = __import__(package,fromlist=[obj])
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/frontend/qt/console/qtconsoleapp.py",
line 56, in <module>
    from IPython.external.qt import QtCore, QtGui
  File
"/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/external/qt.py",
line 43, in <module>
    raise ImportError('Cannot import PySide >= 1.0.3 or PyQt4 >= 4.7')
ImportError: Cannot import PySide >= 1.0.3 or PyQt4 >= 4.7
------------------------------------------------------------------------------------------------------------------------------------------------------
Do you have any idea how I can remediate this eror?
Note that I appended the full path to the Qt/4.8.4/bin directory to the
PATH variable and the
directory Qt/4.8.4/lib to the LD_LIBRARY_PATH env. variable.

Thanks,

Wim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20130312/b918d69b/attachment.html 


More information about the IPython-User mailing list