[IPython-User] %run magic file not found?

Thomas Kluyver takowl@gmail....
Thu Feb 20 20:17:56 CST 2014


On 20 February 2014 18:03, Adam Hughes <hughesadam87@gmail.com> wrote:

> I wasn't able to install the dev version, got something like this:
>
> AssertionError: Missing package data:
> IPython/html/static/components/backbone/backbone-min.js
>

I guess you tried to install from a Github tarball? Unfortunately that
doesn't work since we started using submodules, because 'git archive'
doesn't include them. You'll need to clone the git repo and install from
there.


>
> However I was able to fix the notebook by opening it's source and
> replacing "false" with "False".  This typo was written to every cell
> actually, so it might be a serious bug, but I'm not sure if it has been
> fixed yet, since I didn't get the dev version installed.  Additionally,
> it's not clear to me which modules are responsible for writing the .ipynb
> files, particularly these lines:
>

It's not a bug: the notebook files are in JSON format, and Javascript
spells true and false in lowercase. %run in 1.2 is trying to run them as
Python files, which won't work. In master, %run knows about the .ipynb file
format, so it will read it and run the Python code correctly.

Thomas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20140220/25ebb962/attachment.html 


More information about the IPython-User mailing list