hi all<br>          I am trying to use IPython with wthread option but it always giving me the error given below<br><br> [abhishek@localhost ~]$ ipython -wthread<br>/usr/lib/python2.6/site-packages/IPython/Magic.py:38: DeprecationWarning: the sets module is deprecated<br>
  from sets import Set<br>---------------------------------------------------------------------------<br>AttributeError                            Traceback (most recent call last)<br><br>/usr/bin/ipython in &lt;module&gt;()<br>
     26 import IPython.Shell<br>     27 <br>---&gt; 28 IPython.Shell.start().mainloop()<br>     29 <br>     30 <br><br>/usr/lib/python2.6/site-packages/IPython/Shell.py in start(user_ns)<br>   1231 <br>   1232     shell = _select_shell(sys.argv)<br>
-&gt; 1233     return shell(user_ns = user_ns)<br>   1234 <br>   1235 # Some aliases for backwards compatibility<br><br><br>/usr/lib/python2.6/site-packages/IPython/Shell.py in __init__(self, argv, user_ns, user_global_ns, debug, shell_class)<br>
    880         threading.Thread.__init__(self)<br>    881         self.wx = wx<br>--&gt; 882         self.wx_mainloop = hijack_wx()<br>    883 <br>    884         # Allows us to use both Tk and GTK.<br><br><br>/usr/lib/python2.6/site-packages/IPython/Shell.py in hijack_wx()<br>
    696         import wxPython as wx<br>    697 <br>--&gt; 698     ver = wx.__version__<br>    699     orig_mainloop = None<br>    700     if ver[:3] &gt;= &#39;2.5&#39;:<br><br>AttributeError: &#39;module&#39; object has no attribute &#39;__version__&#39;<br>
Plz help me. I want use for Mayavi2 . My wxPython version 2.8.9 and IPython 0.9.1<br>