Currently files are run before IPython has finished setting itself up.  This is a known problem and there is no simple fix that I know of, but we are working on this.  This will *hopefully* be fixed in 0.11 (we are about to release 0.10.<br>
<br>Cheers,<br><br>Brian<br><br><div class="gmail_quote">On Fri, Jun 26, 2009 at 11:37 AM, Dennis Muhlestein <span dir="ltr">&lt;<a href="mailto:djmuhlestein@gmail.com">djmuhlestein@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
I would like to use ipython with a wx application.<br>
<br>
If I start iPython with -wthread, then, in the shell, I load the script<br>
that loads my application, all seems to work properly.<br>
<br>
<br>
If however, I try to have iPython start my application, iPython doesn&#39;t<br>
drop into the shell until after my script has been run.<br>
<br>
 &gt; ipython -wthread test.py<br>
<br>
It appears the problem is that test.py is evaluated before the shell<br>
enters it&#39;s mainloop function.<br>
<br>
Does anyone know a way to remedy this?<br>
<br>
Preferably, I&#39;d like to provide a script that launches my application,<br>
and if iPython is available, it also drops to an iPython console on the<br>
command line when the application is run.<br>
<br>
Thanks<br>
-Dennis<br>
_______________________________________________<br>
IPython-user mailing list<br>
<a href="mailto:IPython-user@scipy.org">IPython-user@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/ipython-user" target="_blank">http://mail.scipy.org/mailman/listinfo/ipython-user</a><br>
</blockquote></div><br>