On Sat, Aug 6, 2011 at 5:08 PM, Arlindo da Silva <span dir="ltr">&lt;<a href="mailto:dasilva@alum.mit.edu">dasilva@alum.mit.edu</a>&gt;</span> wrote:<br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div class="im">On Sat, Aug 6, 2011 at 12:29 PM, Min RK <span dir="ltr">&lt;<a href="mailto:benjaminrk@gmail.com" target="_blank">benjaminrk@gmail.com</a>&gt;</span> wrote:<br></div><div class="gmail_quote"><div class="im">
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div bgcolor="#FFFFFF"><div>Command-line args are prefixed with &#39;--&#39;, so you want:</div><div><div><span>% ipython-qtconsole --IPythonWidget.in_prompt=&#39;xxx&gt; &#39;</span></div><div><span><br></span></div>
</div><div><span>There are zero options in IPython that cannot be set from the command-line.</span></div><div><span><br></span></div><div><span>Note that this particular prompt won&#39;t work of you are using 0.11 and not trunk, because the released version doesn&#39;t allow prompts that don&#39;t have &#39;%i&#39; for the prompt number. This has been fixed.</span></div>

<div><span><br></span></div></div></blockquote><div><br></div></div><div>Thank you, I think I solved the mystery. I&#39;ve been developing under EPD 7.1-1 which uses 0.11rc1. I got it working once I updated to EPD-7.1-2 which has the actual 0.11 (not rc1) and had the &quot;%i&quot; in it.  There are subtle changes going from 0.11rc1 to 0.11. For one, the command line syntax for properties now has the &quot;--&quot; in front of it, consistent with the documentation.  Probably some bugs have been fixed as well.</div>

<div><br></div></div></blockquote><div><br></div><div><br></div><div>One last thing. Any good reason why &quot;--no-banner&quot; is not implemented for the qtconsole?</div><div><br></div><div>   Arlindo</div></div><br>-- <br>
Arlindo da Silva<br><a href="mailto:dasilva@alum.mit.edu">dasilva@alum.mit.edu</a><br>