<div class="gmail_quote">On 12 August 2011 17:04, Aaron Meurer <span dir="ltr">&lt;<a href="mailto:asmeurer@gmail.com">asmeurer@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

<div id=":148">Why don&#39;t you upload that file to pypi (and mark it as Python 3)?  I<br>
think if you do that at least pip-3.2 should be smart enough to use<br>
it.</div></blockquote></div><br>We asked pypi people about that, and the position seemed to be that we couldn&#39;t have more than one source distribution under the same name. It&#39;s not a major concern, because the plan is to have the next version work with Python 3 by running 2to3 as part of the build process. I&#39;ve done some work towards this already:<br>

<br><a href="https://github.com/ipython/ipython/pull/663">https://github.com/ipython/ipython/pull/663</a><br><a href="https://github.com/takluyver/ipython/tree/py3compat">https://github.com/takluyver/ipython/tree/py3compat</a><br>

<br>If you want to try this, note that at present, you need to do &quot;python3 setup3.py install&quot; to install in Python 3 (I&#39;ll fix that soon). Also, use of a virtualenv is highly recommended, because it&#39;s still very much a work in progress. &quot;virtualenv -p python3 ipy-2to3&quot; should do the trick.<br>

<br>Thanks,<br>Thomas<br><br><br>