Hi Fernando,<div><br></div><div>Thanks for the hypothesis generation. It turns out that indeed we do have a firewall on the network side that was blocking access.  To get IT to open some ports for me, I need to answer the following question, which I couldn&#39;t figure out from the docs (compounded by my limited understanding of, well, the internet):  <span style>whether the ports use UDP or </span><span style>TCP.</span></div>

<div><span style><br></span></div><div><span style>Also, I just want to paranoidly confirm that this server will be secure &quot;out of the box&quot; provided I followed the directions about setting up a password for my notebook and transmitting it via SSL (so that possible intruders don&#39;t get shell-like access to my system).</span></div>

<div><span style><br></span></div><div><font color="#222222" face="arial, sans-serif">Thanks!</font></div><div><font color="#222222" face="arial, sans-serif"><br></font></div><div><font color="#222222" face="arial, sans-serif">Michael</font></div>

<div><br><div class="gmail_quote">On Fri, Jan 6, 2012 at 3:26 PM, Fernando Perez <span dir="ltr">&lt;<a href="mailto:fperez.net@gmail.com">fperez.net@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<div class="im">On Fri, Jan 6, 2012 at 1:15 PM, Michael Waskom &lt;<a href="mailto:mwaskom@stanford.edu">mwaskom@stanford.edu</a>&gt; wrote:<br>
</div><div class="im">&gt; Oh, sorry; I&#39;m using Chrome 16 in both cases.<br>
<br>
</div>A few things to try, though I&#39;m shooting in the dark here:<br>
<br>
- a different client browser on your laptop.<br>
- is it possible that the network you&#39;re on is filtering http traffic?<br>
 You say your firewall is off, but is that also true in the server<br>
(I&#39;m not sure if you were referring to the client only)?<br>
<br>
- try a simpler http server on the server:<br>
<br>
python -m SimpleHTTPServer<br>
<br>
and see if you can connect to it.  If this doesn&#39;t work, then there&#39;s<br>
a network http traffic issue.<br>
<br>
- try disabling ssl and running the notebook over plain http just for<br>
a minute (you can still use a password, it&#39;s just that it will be sent<br>
in plaintext).<br>
<br>
Let us know how it goes...<br>
<span class="HOEnZb"><font color="#888888"><br>
f<br>
</font></span></blockquote></div><br></div>