<html><head></head><body bgcolor="#FFFFFF"><div><br></div><div>On Feb 3, 2012, at 22:14, Youngung Jeong &lt;<a href="mailto:youngung.jeong@gmail.com">youngung.jeong@gmail.com</a>&gt; wrote:<br><br></div><div></div><blockquote type="cite"><div>Hi,<div><br></div><div>I have installed EPD ipython 0.12 on my Mac. And&nbsp;I was following the instruction,</div><div>&nbsp;"<span class="Apple-style-span" style="color: rgb(17, 85, 124); font-weight: bold; line-height: 21px; ">Starting the IPython controller and engines" </span>&nbsp;and stumbled on</div><div>a problem in hooking up my Debian using ipengine. I plan to use a Mac as a controller so that</div><div>I set the the c.HubFactory.ip = '*' and typed&nbsp;</div><div>$&gt; ipcontroller&amp;&nbsp;</div><div><br></div><div>And copied the 'ipcontroller-client.json' file to my Debian where ipython's version is 0.10.</div><div>Then, when I type 'ipengine --file=./where/my/json/file/is' on my Debian</div><div>It gave me the block of the messages as below:</div><div><br></div><blockquote class="webkit-indent-blockquote" style="margin: 0 0 0 40px; border: none; padding: 0px;"><div><div>/usr/lib/pymodules/python2.6/IPython/kernel/enginefc.py:78: DeprecationWarning: Importing class Referenceable1 directly from 'foolscap' is deprecated since Foolscap 0.4.3. Please import foolscap.api.Referenceable instead</div></div><div><div>&nbsp; class FCEngineReferenceFromService(Referenceable, object):</div></div><div><div>/usr/lib/pymodules/python2.6/IPython/kernel/enginefc.py:511: DeprecationWarning: Importing class Referenceable1 directly from 'foolscap' is deprecated since Foolscap 0.4.3. Please import foolscap.api.Referenceable instead</div></div><div><div>&nbsp; class FCRemoteEngineRefFromService(Referenceable):</div></div><div><div>2012-02-04 01:12:20-0500 [-] Log opened.</div></div><div><div>2012-02-04 01:12:20-0500 [-] /usr/lib/pymodules/python2.6/IPython/kernel/scripts/ipengine.py:112: exceptions.DeprecationWarning: Importing class Tub directly from 'foolscap' is deprecated since Foolscap 0.4.3. Please import foolscap.api.Tub instead</div></div><div><div>2012-02-04 01:12:20-0500 [-] Using furl file: /home/youngung/.ipython/security/ipcontroller-engine.furl</div></div><div><div>2012-02-04 01:12:20-0500 [Uninitialized] 'EngineConnector: engine registration failed:'</div></div><div><div>2012-02-04 01:12:20-0500 [Uninitialized] Unhandled Error</div></div><div><div><span class="Apple-tab-span" style="white-space:pre">        </span></div>Traceback (most recent call last):</div><div><div><span class="Apple-tab-span" style="white-space:pre">        </span></div>Failure: twisted.internet.error.ConnectionRefusedError: Connection was refused by other side: 111: Connection refused.</div><div><div><span class="Apple-tab-span" style="white-space:pre">        </span></div></div><div><div>2012-02-04 01:12:20-0500 [Uninitialized] error connecting to controller: Connection was refused by other side: 111: Connection refused.</div></div><div><div>2012-02-04 01:12:20-0500 [-] Main loop terminated.</div></div><div><br></div></blockquote><div>By the way, I have no problem in access my Debian using SSH.&nbsp;Does anyone have any idea?</div><div>Do I also have to install ipython 0.12 on the Debian too?</div></div></blockquote><div><br></div><div>Yes, your IPython versions must match. &nbsp;IPython's parallel computing has been completely rewritten since 0.10.</div><br><blockquote type="cite"><div>
<div><br></div><div>Young</div></div></blockquote><blockquote type="cite"><div><span>_______________________________________________</span><br><span>IPython-User mailing list</span><br><span><a href="mailto:IPython-User@scipy.org">IPython-User@scipy.org</a></span><br><span><a href="http://mail.scipy.org/mailman/listinfo/ipython-user">http://mail.scipy.org/mailman/listinfo/ipython-user</a></span><br></div></blockquote></body></html>